Jack, There seems to be a general disapproval among people here of having nodes access each other's private namespace (the one you get with ~). I'm not sure why, but that is one of the reasons why the wge100 driver does not output to its private namespace. The other reason (and in my opinion the more compelling reason) is that we try to have a standard topic name for each type of sensor. That way if you run a bunch of nodes that are made to work together, they will work together with no remapping at all. For example, if you have a single wge100 camera visible on your network, and you just run a wge100 driver and an image_view, you should see images in the image_view. This behavior is unimportant for people who are building a system, but tries to lower the barrier to entry for people who are using ROS for the first time. As for the node name, roslaunch requires that you set the node name explicitely, so there isn't much point in having the driver pick a nice name for itself. I just put some default, fully expecting that some more informative name will be specified in the .launch file. Does this answer your question? Blaise On Mon, 2010-04-05 at 08:50 -0500, Jack O'Quin wrote: > In the current version of the experimental camera1394 driver, the node > name is the same as the camera name. The output is published as > //camera/image_raw (for compatibility with other image pipeline > drivers) with frame ID "/". > > Looking at the wge100 camera driver I see that its node name is always > wge100_node, and it publishes camera/image_raw. Different cameras are > distinguished by running the node in different namespaces. The frame > ID is set by a parameter. > > Are these differences OK? What naming issues influenced to the wge100 approach?