I agree that yours is probably the best bet for us to push forward with. If you could formally release a version, I'd be happy to help add to it. 1) Should we split the interface and parser/writer? > I like the way you have kept them together, it's easier to read. 2) Which name should we unite under? The C++ equivalent to this package is named urdf_parser. Realistically, it would make sense if eventually we could integrate it into this official package. Until then, I think we should keep with a similar name. urdf_parser_py might make sense but it doesn't really matter to me. What would be nice for me is if we could have a stack (like my robot_model_python) in a repository we could all maintain where my KDL parser and other similar packages could reside. 3) I think that we might want to merge into my package, but would be open > to other suggestions. Does that sound good? > Sounds good to me. It might also be nice to incorporate Thomas' string pretty printing. I'd also personally make a few changes to the URDF class you have if you think they're reasonable. First, make the *parse* and *load * methods static so you can load the URDF object in one line. Secondly, make those two more intuitive by renaming them *parse_xml_string* and * load_xml_file* or something similar. Not making these changes isn't a game-killer though. -Kelsey On Mon, Mar 19, 2012 at 12:44 PM, David Lu!! wrote: > I've gone through all three of our packages, and I believe that mine has > the most features (please correct me if I'm wrong, I'm not just trying to > promote my own package). Kelsey's package has the KDL components which > would be useful to integrate, as well as using ROS geometry messages in the > lower levels. Thomas's package has the nice interface/parse split, as well > as some useful constants. Both have some error checking and the ability to > read rosparams. My has the writing component and I think the fullest set of > supported tags. > > Open questions: > 1) Should we split the interface and parser/writer? > 2) Which name should we unite under? > 3) I think that we might want to merge into my package, but would be open > to other suggestions. Does that sound good? > > -David > > On Fri, Mar 16, 2012 at 3:06 PM, Kelsey Hawkins wrote: > >> I would also like to chime in and say I have partially implemented a URDF >> parser in Python which you can find here: >> http://www.ros.org/wiki/urdf_parser_python I'm not sure if it is >> extensive as David's since there are several sections like the geometry >> components which haven't been fully implemented. I have been successfully >> using this package for several months now in conjunction with the KDL >> parser you can find in the same stack. If either of you decide to >> officially release your packages, I'd be happy to get my KDL parser working >> with the released version. >> >> -Kelsey Hawkins >> >> _______________________________________________ >> ros-users mailing list >> ros-users@code.ros.org >> https://code.ros.org/mailman/listinfo/ros-users >> >> > > _______________________________________________ > ros-users mailing list > ros-users@code.ros.org > https://code.ros.org/mailman/listinfo/ros-users > >