[Ros-release] Dry stack prereleases for groovy

Wim Meeussen wim at hidof.com
Mon Nov 26 19:06:30 UTC 2012

I had done the exact same thing and added the workaround to the
Jenkins setup preamble. This is the verbose output of what actually
gets called:

/usr/bin/c++    -pthread -O2 -g
CMakeFiles/test_unique_id.dir/tests/test_unique_id.cpp.o  -o
../bin/test_unique_id -rdynamic -L/opt/ros/groovy/lib -lroscpp
-lboost_signals-mt -lboost_filesystem-mt -lrosconsole
-lroscpp_serialization -lxmlrpcpp -lrostime -lboost_date_time-mt
-lboost_system-mt -lboost_thread-mt -lpthread -lcpp_common
-l/usr/lib/libgtest.a -Wl,-rpath,/opt/ros/groovy/lib

/usr/bin/ld: cannot find -l/usr/lib/libgtest.a

So somewhere rosmake is using "-l/usr/lib/libgtest.a" instead of "-L
/usr/lib -lgtest". Any suggestions from a rosmake guru?


On Sat, Nov 24, 2012 at 10:02 AM, Brian Gerkey <gerkey at osrfoundation.org>wrote:

> On Fri, Nov 23, 2012 at 7:53 PM, Wim Meeussen <wim at hidof.com> wrote:
> > I tried one of the (ugly) workarounds from the comments above:
> >
> > cd /usr/src/gtest
> > sudo cmake CMakeLists.txt
> > sudo make
> > sudo cp *.a /usr/lib
> >
> > This creates a static library /usr/lib/libgtest.a, but linking fails:
> >
> > Linking CXX executable ../bin/test_unique_id
> >   /usr/bin/ld: cannot find -l/usr/lib/libgtest.a
> FWIW, I've added that workaround to the setup preamble of Jenkins
> builds and it worked fine.  I'm surprised that the linker can't find
> the lib in your case.  I would turn on verbose linker output to figure
> out what's going on there.
>     brian.

Wim Meeussen
CTO, hiDOF Inc.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-release/attachments/20121126/7379b25c/attachment-0009.html>

More information about the Ros-release mailing list