[Ros-release] Pre-release build failed, release build did not

Shaun Edwards shaun.edwards at gmail.com
Tue Jun 4 18:55:33 UTC 2013


I've seen that happen as well.  I actually tried the pre-release build 5
times throughout the day and they all failed.  I may have gotten lucky, so
I sent the original email to see if anybody else had the same experience.


On Tue, Jun 4, 2013 at 1:48 PM, Jack O'Quin <jack.oquin at gmail.com> wrote:

> On Tue, Jun 4, 2013 at 1:36 PM, Shaun Edwards <shaun.edwards at gmail.com>wrote:
>> All,
>> I ran into some strange behavior recently.  I tried to do a pre-release
>> build recently on my abb stack.  I had done one about 2 months ago, but
>> forgot to do a release (I'm losing it).  Despite not making any changes,
>> the pre-release build failed.  I tried several "fixes" but nothing seemed
>> to work.  I compared the abb stack to the motoman stack (already released).
>>  Even though both had nearly the same dependencies, abb wouldn't build.  By
>> that point I had convinced myself that something was wrong with the
>> pre-release.  I went ahead and released abb, which surprisingly built with
>> no problems.  The links for the releases can be found below.  Has anybody
>> else encountered this problem?  What am I missing?
>> ABB Pre-release (precise) :
>> http://build.willowgarage.com//job/prerelease_groovy_abb_precise_amd64/15/
>> ABB release (precise):
>> http://build.willowgarage.com//job/prerelease_groovy_abb_precise_amd64/16/
> Sometimes the build farm will fail for transitory reasons.
> Maybe a bunch of packages you depend on were being rebuilt when your
> pre-release ran. (Only a guess.)
> --
>  joq
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-release/attachments/20130604/3f58ab89/attachment-0009.html>

More information about the Ros-release mailing list