[Ros-release] Hydro pre-release tests

Jack O'Quin jack.oquin at gmail.com
Thu Mar 21 23:29:51 UTC 2013

On Thu, Mar 21, 2013 at 4:08 PM, Tully Foote <tfoote at osrfoundation.org> wrote:
> I think that it might be flagging a missing dependency on catkin correctly.
> I ran this successfully on my machine:
>   bash run_chroot_local precise amd64 /tmp/myworkspace/ prerelease hydro
> ackermann_msgs 0.9.0 ; echo $?

That command works for me, too. I just tried it.

> What was the command you ran?

The one that's failing is:

bash run_chroot_local precise amd64 /tmp/myworkspace/ prerelease hydro
unique_identifier 1.0.0 ; echo $?

That bombs out the same as before...

> On Wed, Mar 20, 2013 at 12:49 PM, Jack O'Quin <jack.oquin at gmail.com> wrote:
>> That helps, thanks.
>> I had to create a /tmp/workspace directory to run that script. After
>> that, it ran for quite a while before failing...
>> {{{
>>   Retrieve the ROS build environment by sourcing /opt/ros/hydro/setup.bash
>>   bash: /opt/ros/hydro/setup.bash: No such file or directory
>>   /!\  Failed to source /opt/ros/hydro/setup.bash
>>   Failed to source /opt/ros/hydro/setup.bash
>> }}}
>> I guess that file was missing in the chroot, it's present on my root
>> system.
>> I had been using a Groovy workspace before running this. Does the
>> script depend on the shell environment from which it was invoked?


More information about the Ros-release mailing list