[ros-users] compile errors in bumblebee_xb3

Morgan Quigley morganquigley at gmail.com
Tue Apr 6 20:57:34 UTC 2010


It looks like you're either missing libdc1394 or you had a different
version. The package compiles on my box against libdc1394 version 22,
which comes with Ubuntu 9.10 (and 9.04, IIRC).

I must warn you that the bumblebee_xb3 package is definitely in
class-project state :)   I just wrote a standalone viewer and a
standalone utility which can dump raw video to disk. My project was
running on a resource-constrained embedded platform, so I couldn't use
the more general tools. I just put the code up on sourceforge in case
it would be useful to anyone who wanted to do a proper ROS driver.

-Morgan



On Tue, Apr 6, 2010 at 12:41 PM,  <sh2723 at columbia.edu> wrote:
> Hi,
>
> When I tried to compile bumblebee_xb3, there were the compile errors below.
>
>
>  /home/joseph/ros/pkgs/cameras/bumblebee_xb3/bumblebee_xb3.cpp:57:
> error: ?DC1394_SUCCESS? was not declared in this scope
>   /home/joseph/ros/pkgs/cameras/bumblebee_xb3/bumblebee_xb3.cpp:58:
> error: ?DC1394_CAPTURE_FLAGS_DEFAULT? was not declared in this scope
>   /home/joseph/ros/pkgs/cameras/bumblebee_xb3/bumblebee_xb3.cpp:58:
> error: ?dc1394_capture_setup? was not declared in this scope
>
>
> Thanks for any comment in advance.
>
> Best,
> Soonhac
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users
>



More information about the ros-users mailing list