[ros-users] rosdep unable to find log4cxx and boost on Ubuntu 10.04 system

Brett Graham graham at rowland.harvard.edu
Mon Apr 26 12:08:32 UTC 2010

I ran into the same issue installing it on Lucid. I had to install the
dependencies manually just as you did. After that, everything worked

On Mon, Apr 26, 2010 at 3:17 AM, Rene Ladan <r.c.ladan at gmail.com> wrote:
> 2010/4/26 Kim Houck <kim_houck at yahoo.com>:
>> I received the following error when I tried to run 'rosdep install
>> turtlesim' for the ros tutorial:
>>     $ rosdep install turtlesim
>>     Failed to find rosdep boost for package turtlesim on OS:ubuntu
>> version:10.04
>>     Failed to find rosdep log4cxx for package turtlesim on OS:ubuntu
>> version:10.04
>>     ERROR: ABORTING: Rosdeps [u'boost', u'log4cxx'] could not be resolved
>> A similar error was presented by rosdep when compiling ROS on the
>> system(running the beta version of Ubuntu 10.04(Lucid Lynx)).  The install
>> was successful however after manually installing the packages in question
>> via apt-get.  Has anyone have any info on how they handled similar issues,
>> or have installed ROS on a Ubuntu 10.04 system without problems?  Any help
>> would be appreciated.  Thanks.
> I suspect that Ubuntu 10.04 is not yet listed in rosdep.yaml (located
> in the root
> directory of ROS), so consequently rosdep does not know how to deal with it.
> Ubuntu 10.04 is to be released coming Thursday.
> Rene
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users

More information about the ros-users mailing list