[ros-users] rosintsall yaml related problems installing ROS on Neo Freerunner

"Jan Tünnermann" jeti at goffa.de
Tue Jul 6 13:58:07 UTC 2010

Hi everyone!

I'm trying to install ROS on the Neo Freerunner Linux Smartphone.
When I run the ./rosinstall I get the following error:

root at neo:~# ./rosinstall
Traceback (most recent call last):
  File "./rosinstall", line 27, in <module>
    import yaml
  File "/usr/lib/python2.6/dist-packages/yaml/__init__.py", line 9, in
    from dumper import *
  File "/usr/lib/python2.6/dist-packages/yaml/dumper.py", line 6, in <module>
    from representer import *

I have also tried to install directly from SVN. Everything in c/c++
compiles fine but Python scripts show similar errors as the one above.

There are several Python versions on the phone (i think 2.4 2.5 2.6) I
tried switsching arround via update-alternatives or setting $PYTHONHOME
with not much effect.

I'm not really familar with debugging python scripts and especially that
it is a "MemoryError" at import confuses me.

Python in general is working, so it must be related to the yaml (installed
python-yaml & yaml & dev-packages) stuff.

Maybe someone has an idea? Has anyone installed ROS on the freerunner?

thanks a lot,

More information about the ros-users mailing list