[ros-users] Rviz issues with pre-compiled installation on Jaunty

Ralf Stauder stauder at servicerobotics.eu
Thu Jul 22 10:39:02 UTC 2010

Hi Mailing List,

I recently installed the pre-compiled ROS boxturtle on a fresh Ubuntu 9.04 Jaunty and couldn't start Rviz at first, so I wanted to share my experiences if someone else might also have those problems (or to avoid them in other versions).

First of all, Using boxturtle on Jaunty is probably a bad idea by itself, considering all the newer versions, but we were bound to those editions in this case.

After the installation of Jaunty I let apt-get update everything it wanted, then installed the ros-boxturtle-base package, everything without problems. Now when I tried to start Rviz, I got a very quick
rosrun: line 35: 10326 Segmentation fault $exepath "$@"

I found a very similar error at https://code.ros.org/discuss/ros-users/browse_frm/thread/908/3292, and recompiling rviz (after deleting the ROS_NOBUILD obviously) solved the problem. So I suppose, that apt-get updated boost, too (I have to admit, I didn't pay any attention to this), and that this somehow caused this problem.

Best regards,
Ralf Stauder

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20100722/5c298dd6/attachment-0002.html>

More information about the ros-users mailing list