[ros-users] RVIZ error

Benoit Larochelle Benoit.Larochelle at dfki.de
Tue Jul 13 13:32:03 UTC 2010

Hi Vinay,

This error looks similar to the one that you get if you try to run RVIZ in a virtual machine:

terminate called after throwing an instance of 'Ogre::RenderingAPIException'
  what():  OGRE EXCEPTION(3:RenderingAPIException): No GLX FBConfig support on your display in GLXGLSupport::GLXGLSupport at OgreGLXGLSupport.cpp (line 788)
/opt/ros/boxturtle/ros/bin/rosrun: line 35:  1634 Aborted                 $exepath "$@"

On my MacBook Pro, here are the drivers if I run Ubuntu 10.4 native and in a VirtualBox VM: 

02:00.0 VGA compatible controller: nVidia Corporation C79 [GeForce9400M] (rev b1)

00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter

I don't know what the second one is, but it does support 3D. I have the 3D Desktop Cube, and it is virtually as fast as native Ubuntu. However, I still cannot run RVIZ (due to Ogre). Tickets have been filed about this problem at VirtualBox and at Ogre, but no one has taken them seriously so far (the tickets have been sitting there for months and are still not assigned), so I doubt that it will be resolved soon.


From: Josh Faust 
Sent: Monday, July 12, 2010 9:04 PM
To: ros-users at code.ros.org 
Subject: Re: [ros-users] RVIZ error

   [please note that I am getting the same error if I just call $rosrun rviz rviz]:
  vros at powerbot:~$ rosrun rviz rviz -d 'rospack find hokuyo_node' /hokuyo_test.vcg
  [ INFO] 1278719927.352134000: Loading general config from [/home/vinaypilania/.rviz/config]
  [ INFO] 1278719927.353486000: Loading display config from [/home/vinaypilania/.rviz/display_config]
  rviz: OgreGLSupport.cpp:57: virtual void Ogre::GLSupport::initialiseExtensions(): Assertion `pcVer && "Problems getting GL version string using glGetString"' failed.

You need a graphics card and drivers that support full 3D acceleration.  Without knowing what graphics card your computer has I can't tell you what to look for. 

  This error is mentioned in the troubleshooting. According to troubleshooting Do I need to install graphics driver compatible to my laptop for ubuntu 9.04 or to install OpenGL. Please not that I have installed ROS on other computer there I am not getting this error [only for $ rosrun rviz rviz  ] but there I tested slam_gmapping package in the tutorial http://www.ros.org/wiki/slam_gmapping/Tutorials/MappingFromLoggedData.
   In the end of this tutorial in "3. Variation: watching the mapping progress", I am getting one error that is "graphics driver does not support 2000*2000" grid/array [approx]. From all these testing it seems that there is some problem with rviz.

Please copy error messages exactly.  That error is probably not a big deal, it just means the map you're seeing has been downsampled to a resolution that your graphics card supports.



ros-users mailing list
ros-users at code.ros.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20100713/5e81916c/attachment-0003.html>

More information about the ros-users mailing list