[ros-users] rosinstall gets stuck during checkout

Achtelik Markus markus.achtelik at mavt.ethz.ch
Wed Jul 14 09:19:37 UTC 2010

short update:

this happened on virtual machines, when the network setting was in NAT
mode, bridged mode worked perfectly.
This works for me now, but any idea why this happens? Are there some

Best, Markus 

-----Original Message-----
From: ros-users-bounces at code.ros.org on behalf of Achtelik  Markus
Sent: Tue 7/13/2010 12:06
To: ros-users at code.ros.org
Subject: [ros-users] rosinstall gets stuck during checkout
Hi all,
I'm trying to install cturtle on several Ubuntu 10.04 machines from svn with the following command in the home-directory:
./rosinstall ros_cturtle http://ros.org/rosinstalls/cturtle_base.rosinstall <http://ros.org/rosinstalls/cturtle_base.rosinstall> 

During checkout, rosinstall gets stuck. This happens at different positions, e.g. one time somwhere while checking out https://code.ros.org/svn/ros/stacks/ros/tags/cturtle <https://code.ros.org/svn/ros/stacks/ros/tags/cturtle>  and when I tried it again, it was at the beginning of https://code.ros.org/svn/ros-pkg/stacks/camera_drivers/tags/cturtle <https://code.ros.org/svn/ros-pkg/stacks/camera_drivers/tags/cturtle>  .
When I cancel the installation by ctrl-c, I get:
ERROR: Failed to install tree 'stacks/camera_drivers' using command:
 svn co  https://code.ros.org/svn/ros-pkg/stacks/camera_drivers/tags/cturtle <https://code.ros.org/svn/ros-pkg/stacks/camera_drivers/tags/cturtle>  /home/markus/ros/ros_cturtle/stacks/camera_drivers
Perhaps there is another installation in the way, or there are permissions issues.

I let ros create the installation folder, so I don't think there is an installation in the way. I just downloaded the latest rosinstall. 
Checking out the repositories manually works perfectly, so I don't think there are networking issues.
Any ideas what's going wrong?
Thanks for your help!
Best, Markus
ros-users mailing list
ros-users at code.ros.org

More information about the ros-users mailing list