[ros-users] unable to build gazebo on ROS

treanorj jenny.treanor at gmail.com
Tue Jul 27 15:32:34 UTC 2010

Hi John,

thanks a million, that worked great. I had to remove the libogre-dev that
was still in my system, remove the CMakeCache.txt as you suggested and
rebuilt all.

Then I had an issue with a missing libgazebo_ros_time.so, but fixed that,
(saw the related thread). 

I am currently following one of the tutorials on gazebo simulation at
http://www.ros.org/wiki/simulator_gazebo/Tutorials/Gazebo_ROS_API, but have
tried the spinning top example aswell with the same new error. I have had a
look around elsewhere and can't find much if any reference to it. 

If I run roslaunch gazebo_worlds empty_world.launch 
the gazebo window opens fine. But then if I type in a new terminal 
rosrun gazebo spawn_model (with any ending)
(e.g. rosrun gazebo spawn_model -file `rospack find
gazebo_worlds`/objects/desk1.model -gazebo -model desk1 -x 0
I get an error: 
[rosrun] Couldn't find executable named spawn_model below

again any help/pointers would be really great,

thanks for your time!

View this message in context: http://ros-users.122217.n3.nabble.com/unable-to-build-gazebo-on-ROS-tp825834p999646.html
Sent from the ROS-Users mailing list archive at Nabble.com.

The Palm PDK Hot Apps Program offers developers who use the
Plug-In Development Kit to bring their C/C++ apps to Palm for a share 
of $1 Million in cash or HP Products. Visit us here for more details:
ros-users mailing list
ros-users at lists.sourceforge.net

More information about the ros-users mailing list