[ros-users] Stage Simulation

Suraj Swami suraj.g.swami at gmail.com
Sun Mar 7 09:37:44 UTC 2010


I am trying to use  the Stage simulation. I am following the tutorial given
on the site


I am able to run the simulation environment and even the command

rosrun teleop_base teleop_base_keyboard base_controller/command:=cmd_vel

But I get a very slow response to the inputs typed on the keyboard. I see
the robot moving very  slowly and after few minutes. Later on the blue robot
just disappears from the screen.

Do I need to change any parameters in the world file ?
I even tried changing the world file to

interval_sim 1  # simulation timestep in milliseconds
interval_real 1  # real-time interval between simulation updates in

But I still get the same response.

I have one more concern.

I was not able to run the command
rosrun rviz rviz -d rviz/stage.vcg

I get the following error.
No protocol specified
Error: Unable to initialize gtk, is DISPLAY set properly?

The result of the command $ echo $DISPLAY

Basically I trying to use ROS for a good simulation environment for my
project. Do you recommend me to use Stage or do we have a new simulation
environment by ROS ?

Thank you.

Suraj Swami
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20100307/60ab015f/attachment-0004.html>

More information about the ros-users mailing list