[ros-users] Running error in camera1394

sh2723 at columbia.edu sh2723 at columbia.edu
Mon May 3 17:44:44 UTC 2010

Hi Jack,

When I ran "rosdep install camera1394", the messages are as followings.

joseph at tonga:~/rospkgs/cameras/camera1394$ rosdep install camera1394
executing this script:
  set -o errexit
#No Packages to install
if [ ! -f /opt/ros/lib/liblog4cxx.so.10 ] ; then
   mkdir -p ~/ros/ros-deps
   cd ~/ros/ros-deps
   wget --tries=10  
   tar xzf apache-log4cxx-0.10.0-wg_patched.tar.gz
   cd apache-log4cxx-0.10.0
   ./configure --prefix=/opt/ros
   sudo make install

if [ ! -f /opt/ros/lib/libboost_date_time-gcc42-mt*-1_37.a ] ; then
   mkdir -p ~/ros/ros-deps
   cd ~/ros/ros-deps
   wget --tries=10 http://pr.willowgarage.com/downloads/boost_1_37_0.tar.gz
   tar xzf boost_1_37_0.tar.gz
   cd boost_1_37_0
   ./configure --prefix=/opt/ros
   sudo make install

I think the problem is that there wasn't  
libboost_iostreams-gcc42-mt-1_37.so.1.37.0 in /opt/ros/lib. Should I  
reinstall ROS?


Quoting Jack O'Quin <jack.oquin at gmail.com>:

> On Thu, Apr 29, 2010 at 9:29 PM, Soonhac Hong <soonhac.hong at gmail.com> wrote:
>> Hi Jack,
>> The OS is Ubuntu Hardy.
>> When I tried to find this library in
>> /opt/ros/lib/libboost_iostreams-gcc42-mt-1_37.so.1.37.0, I couldn't find
>> it there.
> Hmm. What happens if you run "rosdep install camera1394"?
> --
>  joq
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users

More information about the ros-users mailing list