[ros-users] rviz on snow leopard

Nicholas Butko nbutko at ucsd.edu
Fri May 14 21:01:47 UTC 2010

As far as I can tell, wxWidgets 2.8 is never planned to work on 10.6 (in 64-bit mode). 3.0, due out sometime this year, is supposed to work. Also the development version of wxWidgets (2.9) is claimed to work. 

One possible workaround is to modify the py25-wxpython portfile to depend on the wxWidgets-devel package rather than the wxWidgets package.

I've never tried this, but would be interested to hear if it works. Unfortunately, this is a stopgap solution, because you will probably want to link to the stable 3.0 version when it is released. 

Does anyone have experience working around this problem?


On May 14, 2010, at 1:49 PM, Josh Faust wrote:

> You're right, there are many other dependencies I didn't have. I tried now the -r flag and some dependencies compiled but I stuck again, this time it is the py25-wxpython which doesn't compile giving the attached output.
> Looks like port's py25-wxpython package is broken on snow leopard: https://trac.macports.org/ticket/23438
> Do you have some experience with that? I tried to get some help directly for the py25-wxpython issue but didn't get anything until now.
> Did someone successfully install rviz on snow leopard?
> I don't unfortunately, my test machine is on 10.5 still.  You could try installing the python 2.6 versions of things and using python_select to choose 2.6 instead of 2.5, but that also may not work.
> Josh
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20100514/254e99ba/attachment-0003.html>

More information about the ros-users mailing list