[ros-users] ros debian

Bill Morris morris at ee.ccny.cuny.edu
Thu May 27 11:09:26 UTC 2010

On Thu, 2010-05-27 at 03:53 -0700, Narasimhan wrote: 
> i tried tully's method. it almost worked. 
> i downloaded the svn for ros-boxturtle-base using --nobuild.
> i copied the entire ros folder in my home directory to usb. from usb i
> pasted it to home folder of campus pc. i edited the setup.sh.
> i ran "cd ~/ros && make"  it said makefile not found.
> then i navigated to ~\ros and found that there is no makefile. there were
> ros folder, stack folder, setup.sh and this.install.
> then when i went inside the ros folder(~\ros\ros) the makefile was there.
> so i tried  "cd ~/ros/ros && make" it did work. some sequence of commands
> got executed and it was followed by some random junk(the entire terminal
> screen was full of junk for some 10 min) and it was followed by some
> sequence of commands and finally a build error(i forgot the number).
> then i tried some few commands. rosls roscd and few other commands worked
> but rosdep and rosmake(same junk appeared for 10min followed by error)
> didn't work.
> so can someone suggest some other method

Things to try

setup.sh needs to be run to setup your paths.

you can either run
$ source ~/ros/setup.sh

or you can add 
source ~/ros/setup.sh
to the end of the file ~/.bashrc

rosmake should work at this point

There are often no makefiles because cmake generates the makesfiles
once rosmake is working try running

Next install the packages you need to run ros
$ rosdep install ros

Then make ros, this will take a while.
$ rosmake ros

After this you should be able to run roscore
$ roscore

At this point you should be able to start the tutorials

One way to manually make the makefiles which sometimes fixes things is
to try this in the directory where the makefile is missing
$  cmake CMakeLists.txt

More information about the ros-users mailing list