[ros-users] ros debian

Brian Gerkey gerkey at willowgarage.com
Thu May 27 16:36:02 UTC 2010

On Thu, May 27, 2010 at 3:53 AM, Narasimhan <narasimhan1990 at yahoo.co.in> wrote:
> i tried tully's method. it almost worked.
> i downloaded the svn for ros-boxturtle-base using --nobuild.
> i copied the entire ros folder in my home directory to usb. from usb i
> pasted it to home folder of campus pc. i edited the setup.sh.
> i ran "cd ~/ros && make"  it said makefile not found.
> then i navigated to ~\ros and found that there is no makefile. there were
> ros folder, stack folder, setup.sh and this.install.
> then when i went inside the ros folder(~\ros\ros) the makefile was there.
> so i tried  "cd ~/ros/ros && make" it did work. some sequence of commands
> got executed and it was followed by some random junk(the entire terminal
> screen was full of junk for some 10 min) and it was followed by some
> sequence of commands and finally a build error(i forgot the number).
> then i tried some few commands. rosls roscd and few other commands worked
> but rosdep and rosmake(same junk appeared for 10min followed by error)
> didn't work.

hi Narasimhan,

To help debug a problem like this (indeed, almost any problem), we
need more specific information.  Please include a sample of the
"random junk" that you saw, and the errors that resulted.  Be sure to
copy and paste (as opposed to manually typing) this text directly into
your email client.


More information about the ros-users mailing list