[ros-users] Issues with rosdep & installation path

Tully Foote tfoote at willowgarage.com
Thu May 27 22:30:54 UTC 2010

Installing no packages is expected.  rosdep tests whether the packages
required are installed already, and will not try to install them if they are

However, the many overrides suggest that yout have set ROS_HOME to ~/ros/ros
 ROS_HOME if set should be a writable directory preferably out side of
source control which which is the default location for log files and a few
other things.  See http://www.ros.org/wiki/ROS/EnvironmentVariables#ROS_HOME

As for multiple copies of ROS installed.  They will not interfere with each
other as long as only one of them is on your ROS_PACKAGE_PATH and ROS_ROOT.
 The one in ~/ros sounds like you installed it from source.  You can use
either the binary based install or the source based install as long as you
are consistent.


On Thu, May 27, 2010 at 9:20 AM, Shankaranand Jagadeesan <sjagad4 at uic.edu>wrote:

>  Hi,
> I'm new to ROS and have been going through the tutorials and everything
> seems to work. But I have a couple of questions. When i use rosdep to
> install the system dependencies I get the following warning and in the end
> it says #No packages to install. But rosmake works perfectly well and I'm
> able to run the tutorials. I want to make sure that rosdep is working. The
> following is the output even if i try to use rosdep against (all) any other
> packages.
> rosdep install turtlesim
> ROSDEP_OVERRIDE: python-matplotlib being overridden with python-matplotlib
> from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: apr being overridden
> with libapr1-dev libaprutil1-dev from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: libxml2 being overridden with libxml2-dev from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: python-fuse being overridden
> with python-fuse from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE:
> python-scipy being overridden with python-scipy from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: ant being overridden with ant
> from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: zziplib being overridden
> with libzzip-0-13 libzzip-dev from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: wxpython being overridden with python-wxgtk2.8 from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: curl being overridden with
> libcurl4-openssl-dev from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE:
> libxaw being overridden with libxaw7-dev from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: sbcl being overridden with sbcl from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: python-yaml being overridden
> with python-yaml from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: bzip2
> being overridden with libbz2-dev from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: intltool being overridden with intltool from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: java being overridden with
> sun-java6-jdk from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: wxwidgets
> being overridden with libwxgtk2.8-dev from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: opengl being overridden with libgl1-mesa-dev
> libglu1-mesa-dev from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE:
> automake being overridden with automake from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: scons being overridden with scons from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: libstdc++5 being overridden
> with libstdc++5 from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: cppunit
> being overridden with libcppunit-dev from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: dpkg-dev being overridden with dpkg-dev from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: libxext being overridden with
> libxext-dev from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: boost being
> overridden with libboost1.40-all-dev from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: log4cxx being overridden with liblog4cxx10-dev from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: qt4 being overridden with
> libqt4-core libqt4-dev qt4-dev-tools from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: unzip being overridden with unzip from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: ncurses being overridden with
> libncurses5-dev from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: swig
> being overridden with swig from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: python-numpy being overridden with python-numpy from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: gtk2 being overridden with
> libgtk2.0-dev from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: libtool
> being overridden with libtool libltdl-dev from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: octave being overridden with octave3.0-headers from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: graphviz being overridden
> with graphviz from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: ruby being
> overridden with ruby from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE:
> python-gtk2 being overridden with python-gtk2 from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: fltk being overridden with
> libfltk1.1-dev from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: doxygen
> being overridden with doxygen from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: zlib being overridden with zlib1g-dev from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: python-imaging being
> overridden with python-imaging from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: fakeroot being overridden with fakeroot from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: python being overridden with
> python-dev from /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: autoconf
> being overridden with autoconf from /home/fit/ros/ros/rosdep.yaml
> ROSDEP_OVERRIDE: libxxf86vm being overridden with libxxf86vm-dev from
> /home/fit/ros/ros/rosdep.yaml ROSDEP_OVERRIDE: pkg-config being overridden
> with pkg-config from /home/fit/ros/ros/rosdep.yaml executing this script:
>  set -o errexit
>  #No Packages to install
> The second query is, why do I have two installations of ros in my file
> system. I use ubuntu karmic and I installed the ROS & base using the
> pre-compiled binaries as told in ROS wiki. I can see ROS and its stacks in
> opt/ros/boxturtle and in ~/ros/ros with tutorials in ~/ros-tutorials. I get
> confused when i set the env variables cause I don't know where to set
> ROS_ROOT. I ran all the tutorials with ~/ros/ros as my ROS_ROOT and it
> worked fine except for rosdep. So if i want to install a new package, Can i
> proceed with ~/ros/ros as my ROS_ROOT?. I would be grateful, If somebody
> could help me with this.
> -
> Thanks & Regards
> Shankaranand Jagadeesan
> Research Assistant, Computer Vision & Robotics Lab
> Dept of Electrical & Computer Engineering
> Graduate Assistant, Liautaud Graduate of School of Business, UIC.
> email:sjagad4 at uic.edu <email%3Asjagad4 at uic.edu>, Phone : 3122185453
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users

Tully Foote
Systems Engineer
Willow Garage, Inc.
tfoote at willowgarage.com
(650) 475-2827
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20100527/54b32c8b/attachment-0003.html>

More information about the ros-users mailing list