[ros-users] Error starting stageros: XRequest.137: BadWindow

Andreas Baldinger e0929191 at student.tuwien.ac.at
Sun Nov 21 16:27:52 UTC 2010


A week ago stageros worked perfectly. Now I tried to start again and I  
always get the same error:

[ INFO] [1290356178.217601386]: Starting program...
[ INFO] [1290356178.217768326]: Waiting for sensor data...
XRequest.137: BadWindow (invalid Window parameter) 0x5400004
[stageros-2] process has died [pid 16149, exit code -11].
The problem is I don´t really know what I changed in this week and I  
couldn´t find any useful information so far.
The log-file contains:

[roscpp_internal] [2010-11-21 17:16:18,316] [thread 0x7fe960960840]:  
[DEBUG] UDPROS server listening on port [51346]
[roscpp_internal] [2010-11-21 17:16:18,322] [thread 0x7fe960960840]:  
[DEBUG] Started node [/stageros], pid [16149], bound on [ndsnotebook],  
xmlrpc port [44758], tcpros port [54024], logging to  
using 	[real] time
[roscpp_internal] [2010-11-21 17:16:18,342] [thread 0x7fe94d15c710]:  
[DEBUG] Accepted connection on socket [10], new socket [15]
[roscpp_internal] [2010-11-21 17:16:18,342] [thread 0x7fe94d15c710]:  
[DEBUG] TCPROS received a connection from []
[roscpp_internal] [2010-11-21 17:16:18,342] [thread 0x7fe94d15c710]:  
[DEBUG] Connection: Creating TransportSubscriberLink for topic [/rosout]  
connected to [callerid=[/rosout] address=[TCPROS connection to  
[ on socket 15]]]

I figured the problem could be anything regarding my graphic card.
I also installed a lot of updates (ubuntu update manager) and there were  
also some ros-updates included.

btw: I´m using ubuntu 10.04 lucid on a Samsung R580 Hawk with a NVIDIA  

Has anyone else ever had such an error?

Andreas Baldinger
MatrNr.: 0929191
Student Automatisierungstechnik
TU Wien

More information about the ros-users mailing list