[ros-users] serial_port package failing to compile

Matt McLellan mattmclel at gmail.com
Mon Nov 22 04:11:57 UTC 2010


I'm having a problem building a package that has serial_port as a
dependency.  When I run 'rosmake', I get the following message in the

[rosbuild] Building package serial_port
  [rosbuild] Including /opt/ros/cturtle/ros/core/rospy/cmake/rospy.cmake
  [rosbuild] Including /opt/ros/cturtle/ros/core/roscpp/cmake/roscpp.cmake
  [rosbuild] Including /opt/ros/cturtle/ros/core/roslisp/cmake/roslisp.cmake
  -- Configuring done
  CMake Error: Unable to open cache file for save.
  CMake Error: : System Error: Permission denied

I've made sure that all users/groups/etc have read/write access to the
CMakeCache.txt file, but it still doesn't seem to work.

I'm using cturtle with the serial_port package, output from 'uname
-a': Linux robot-brain 2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:26:08
UTC 2010 i686 GNU/Linux

Any help is greatly appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20101121/ffeac05b/attachment-0002.html>

More information about the ros-users mailing list