[ros-users] serial_port package failing to compile

Blaise Gassend blaise at willowgarage.com
Mon Nov 22 17:08:04 UTC 2010

It says "System Error: Permission denied", referring to
"/opt/ros/cturtle/stacks/serial_port/build/CMakeCache.txt". Is it
possible that you compiled as root, and are now trying to compile as
yourself? I would recommend looking at file permissions to fix this

On Sun, Nov 21, 2010 at 8:11 PM, Matt McLellan <mattmclel at gmail.com> wrote:
> Hi,
> I'm having a problem building a package that has serial_port as a
> dependency.  When I run 'rosmake', I get the following message in the
> terminal:
> [rosbuild] Building package serial_port
>   [rosbuild] Including /opt/ros/cturtle/ros/core/rospy/cmake/rospy.cmake
>   [rosbuild] Including /opt/ros/cturtle/ros/core/roscpp/cmake/roscpp.cmake
>   [rosbuild] Including /opt/ros/cturtle/ros/core/roslisp/cmake/roslisp.cmake
>   -- Configuring done
>   CMake Error: Unable to open cache file for save.
> /opt/ros/cturtle/stacks/serial_port/build/CMakeCache.txt
>   CMake Error: : System Error: Permission denied
> I've made sure that all users/groups/etc have read/write access to the
> CMakeCache.txt file, but it still doesn't seem to work.
> I'm using cturtle with the serial_port package, output from 'uname
> -a': Linux robot-brain 2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:26:08
> UTC 2010 i686 GNU/Linux
> Any help is greatly appreciated.
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users

More information about the ros-users mailing list