[ros-users] Error starting stageros: XRequest.137: BadWindow

Andreas Baldinger e0929191 at student.tuwien.ac.at
Mon Nov 22 17:24:33 UTC 2010


How can I use gdb and roslaunch together and get a backtrace?
My launch-command is:

	roslaunch robotcontrol exercise01.launch rc:=1

The only way I know to use gdb is: $ gdb [filename]


On 2010-11-22 16:19, Brian Gerkey wrote:
> Looks like stageros is segfaulting (hence the -11 exit code).  Can you
> run it in gdb and post a backtrace?
>On Mon, Nov 22, 2010 at 7:05 AM, Andreas Baldinger
> <e0929191 at student.tuwien.ac.at> wrote:
> > Thank you for your help, but that didn´t help at all.
> > I still get the Error:
> >
> > XRequest.137: BadWindow (invalid Window parameter) 0x4e00004
> > [stageros-2] process has died [pid 4294, exit code -11].
> >
> > I tried to remove my xserver-xorg and install it again, but that didn´t
> > help either.
> > The problem is I am new to linux (4weeks+) and can´t really determine  
> from
> > where the error is coming.
> > I mean what is an XRequest.137? Couldn´t find any information on this
> > either.
> > And how come that it worked a week ago and now its jammed?
> >
> > Greetings,
> > --
> > Andreas Baldinger
> > MatrNr.: 0929191
> > Student Automatisierungstechnik
> > TU Wien
> >
> >
> > On 2010-11-21 23:52, Kevin Watts wrote:
> >> Andreas-
> >> $ export STAGEPATH=/etc/X11
> >>Kevin
> >>On Sun, Nov 21, 2010 at 8:27 AM, Andreas Baldinger <
> >> e0929191 at student.tuwien.ac.at> wrote:
> >>> Hello.
> >> >
> >> > A week ago stageros worked perfectly. Now I tried to start again  
> and I
> >> > always get the same error:
> >> >
> >> > [ INFO] [1290356178.217601386]: Starting program...
> >> > [ INFO] [1290356178.217768326]: Waiting for sensor data...
> >> > XRequest.137: BadWindow (invalid Window parameter) 0x5400004
> >> > [stageros-2] process has died [pid 16149, exit code -11].
> >> >
> >> > The problem is I don´t really know what I changed in this week and I
> >> > couldn´t find any useful information so far.
> >> > The log-file contains:
> >> >
> >> > [roscpp_internal] [2010-11-21 17:16:18,316] [thread 0x7fe960960840]:
> >> > [DEBUG] UDPROS server listening on port [51346]
> >> > [roscpp_internal] [2010-11-21 17:16:18,322] [thread 0x7fe960960840]:
> >> > [DEBUG] Started node [/stageros], pid [16149], bound on  
> [ndsnotebook],
> >> > xmlrpc port [44758], tcpros port [54024], logging to
> >> >
> >> >
> >>  
> [/home/andreasbaldinger/.ros/log/aba5a5f2-f58a-11df-bc8a-0024545bc34c/stageros-2.log],
> >> > using   [real] time
> >> > [roscpp_internal] [2010-11-21 17:16:18,342] [thread 0x7fe94d15c710]:
> >> > [DEBUG] Accepted connection on socket [10], new socket [15]
> >> > [roscpp_internal] [2010-11-21 17:16:18,342] [thread 0x7fe94d15c710]:
> >> > [DEBUG] TCPROS received a connection from [127.0.1.1:34869]
> >> > [roscpp_internal] [2010-11-21 17:16:18,342] [thread 0x7fe94d15c710]:
> >> > [DEBUG] Connection: Creating TransportSubscriberLink for topic
> >> [/rosout]
> >> > connected to [callerid=[/rosout] address=[TCPROS connection to
> >> > [127.0.1.1:34869 on socket 15]]]
> >> >
> >> > I figured the problem could be anything regarding my graphic card.
> >> > I also installed a lot of updates (ubuntu update manager) and there
> >> were
> >> > also some ros-updates included.
> >> >
> >> > btw: I´m using ubuntu 10.04 lucid on a Samsung R580 Hawk with a  
> NVIDIA
> >> > GT330M.
> >> >
> >> > Has anyone else ever had such an error?
> >> >
> >> > Greetings,
> >> > --
> >> > Andreas Baldinger
> >> > MatrNr.: 0929191
> >> > Student Automatisierungstechnik
> >> > TU Wien
> >> > _______________________________________________
> >> > ros-users mailing list
> >> > ros-users at code.ros.org
> >> > https://code.ros.org/mailman/listinfo/ros-users
> >> >
> >> _______________________________________________
> >> ros-users mailing list
> >> ros-users at code.ros.org
> >> https://code.ros.org/mailman/listinfo/ros-users
> > _______________________________________________
> > ros-users mailing list
> > ros-users at code.ros.org
> > https://code.ros.org/mailman/listinfo/ros-users
> >
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users
>



More information about the ros-users mailing list