[ros-users] Error while successful "sudo apt-get install ros-diamondback-desktop-full"

Isaac Saito isaterina at hotmail.com
Thu Aug 4 17:06:59 UTC 2011

Hi all,

I got stuck while installation. See below for the detail. Any thoughts
would be appreciated.

 - While running "sudo apt-get install ros-diamondback-desktop-full"
after downloading a few hundred MB of data, it suddenly quitted and
showed "E: Unable to locate package ros-diamondback-desktop-full"
 - Output of apt-get update:
      <- For the ROS part, the result is the same on another computer
that successfully installed diamondback.
 - Output of installable ROS packages on the computer. You'll see
diamondback packages are missing:

Tried workaround:
 - The things discussed in the pages below are already tried.
 - sudo rm /var/cache/apt/archives/*ros*
 - Reboot OS.

Other: As mentioned earlier, another computer which is on the same
network has successfully installed diamondback. And after apt-get
update on the same machine, apt-get still shows ros-diamondback as
installable packages.

Env: Ubuntu 10.10 Maverick

Thanks in advance.


More information about the ros-users mailing list