[ros-users] rosinstall (electric) fails on OSX10.7, +2 fixes.

Nicholas Butko nbutko at ucsd.edu
Wed Aug 31 17:43:28 UTC 2011

I just tried to install ROS (Electric) on OSX10.7 on my machine. I ran into
two hurdles. Here are the fixes:

1: rosinstall fails, says no yaml python module.
Cause: rosinstall is using the wrong python (/usr/bin/python), pyyaml was
installed with macports.
Solution: edit /usr/local/bin/rosinstall, replace "#!/usr/bin/python" with
"#!/usr/bin/env python".
Ticket: https://code.ros.org/trac/ros/ticket/3660

2: rosmake fails, with a compiler segfault in rosconsle
I was disappointed to find that this is a known bug, with a known fix, and
has been known for weeks prior to release. I'm sorry to see that a version
of ros shipped with what is essentially a fatal issue in its core library.
It seems this is a bug in Apple's llvm-gcc, and I know that OSX is not
officially supported in ROS, and that there are a lot of hard issues that WG
doesn't have time to support. This one takes a few minutes, and the
workaround while not ideal seems harmless. A simple #ifdef __APPLE__ could
have even made the workaround only for OSX platforms, leaving Ubuntu
Here is the bug/fix: https://code.ros.org/trac/ros/ticket/3626
It works. Thanks William for the workaround.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20110831/e54f2605/attachment-0001.html>

More information about the ros-users mailing list