[ros-users] image_pipeline in Electric

Carlos J. ubuntuslave at gmail.com
Sat Aug 6 01:43:37 UTC 2011

On Fri, Aug 5, 2011 at 6:23 PM, Jack O'Quin <jack.oquin at gmail.com> wrote:

> On Fri, Aug 5, 2011 at 5:13 PM, Carlos J. <ubuntuslave at gmail.com> wrote:
> > Perhaps, it's only my case, but I'm experiencing problems with
> > image_pipeline packages, such as image_view and camera_calibration. They
> > seem related to wxWidgets. These problems occur only under electric. The
> > same packages seem to work fine under diamondback. I'm just crying out
> loud
> > to see if it's not just me who is experiencing this.
> More information would be helpful.

> What system are you running? What packages did you try?
> I'm using Ubuntu 11.04 and these 2 problems (that I'm aware of) only
happens only in ROS Electric.

1) When trying to run "image_view" (with all kind of images...tried
different Image topics), I get this:
   $ rosrun image_view image_view image:=/camera/rgb/image_color
   [rospack] warning: ignoring duplicate "nodelet" tag in export block
   init done
   opengl support available

   (<unknown>:15605): GLib-GObject-WARNING **: invalid uninstantiatable type
`(null)' in cast to `GtkWidget'

   (<unknown>:15605): GLib-GObject-WARNING **: instance of invalid
non-instantiatable type `(null)'

   (<unknown>:15605): GLib-GObject-CRITICAL **: g_signal_connect_data:
assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

2) With "camera_calibration", I get errors as following:
   $ rosrun camera_calibration cameracalibrator.py BLABLABLAH
   Traceback (most recent call last):
line 50, in <module>
       import cv2
   ImportError: /usr/local/lib/python2.7/dist-packages/cv2.so: undefined
symbol: _ZNK2cv5flann5Index12getAlgorithmEv

What results did you expect? What did you get?
None of these problems occur when I use (switch back) to diamondback. The
packages work as expected in diamondback. I have tried both binary and
from-source packages with the same results.

I hope this could give you an idea of the problem.

Thanks a lot for looking into it!


> --
>  joq
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20110805/71311db1/attachment-0002.html>

More information about the ros-users mailing list