[ros-users] ROS in MacOSX (just concerns)

William Woodall wjwwood at gmail.com
Wed Aug 24 04:13:59 UTC 2011

To add to what John said, no this is not going to be as easy as Linux for
now (we are working on that).  OpenCV should work, and usb cameras might
work, but I haven't tried them.

I don't know about the make eclipse-project command not working, could you
give more detail on this (errors?)?

Also, the wiki page is out of date, use these directions:

I would say that OS X right now is not ready for production work if you want
rviz and the like to work.  If you are looking to get things done I would
recommend using Linux until OS X support improves a little more over the
next few months.

Hope that helps,

William Woodall
Graduate Software Engineering
Auburn University
w at auburn.edu
wjwwood at gmail.com

On Tue, Aug 23, 2011 at 10:35 PM, John Harrison <ash.gti at gmail.com> wrote:

> Did you follow the instructions on
> https://github.com/wjwwood/ros-osx/tree/master/electric-lion-homebrew ?
> William and I have been working to get everything working on OS X, at this
> point we have made progress but its not as well tested as the linux
> distributions.
> https://github.com/wjwwood/ros-osx/wiki/ROS,-Electric-Emys,-on-OS-X-10.7-Lion-using-HomebrewHas a list of the packages we have gotten to work with OS X 10.7.
> On Tue, Aug 23, 2011 at 10:17 PM, Carlos J. <ubuntuslave at gmail.com> wrote:
>> I'm trying to use ROS in MacOSX after successfully installing (not
>> completely tested yet...stuff like rviz doesn't work...Ogre is ugly to
>> install and it fails through macports). I'm not sure what to expect ...will
>> other things be as simple to just install and play like in Linux? Will
>> OpenCV work? will my uvc cameras work?
>> I would like people's opinions about this transition (please, don't bash
>> me for the ridiculous question). I would like to have a feel of how many
>> actual mac users are having ROS working successfully. As I said, my roscore
>> works and got the desktop-full install fine (no errors), but I ran into the
>> case where rviz is there but it's NOT there really...
>> Why does stuff like "make eclipse-project" doesn't work in here?
>> Thanks for the positive/negative vibes to whoever feels my position.
>> Carlos
>> _______________________________________________
>> ros-users mailing list
>> ros-users at code.ros.org
>> https://code.ros.org/mailman/listinfo/ros-users
> --
> John Harrison
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20110823/894d8b6b/attachment-0002.html>

More information about the ros-users mailing list