[ros-users] rosinstall (electric) fails on OSX10.7, +2 fixes.

Troy Straszheim straszheim at willowgarage.com
Wed Aug 31 17:59:07 UTC 2011

On Wed, Aug 31, 2011 at 10:43 AM, Nicholas Butko <nbutko at ucsd.edu> wrote:

> I just tried to install ROS (Electric) on OSX10.7 on my machine. I ran into
> two hurdles. Here are the fixes:
> 2: rosmake fails, with a compiler segfault in rosconsle
> I was disappointed to find that this is a known bug, with a known fix, and
> has been known for weeks prior to release. I'm sorry to see that a version
> of ros shipped with what is essentially a fatal issue in its core library.
> It seems this is a bug in Apple's llvm-gcc, and I know that OSX is not
> officially supported in ROS, and that there are a lot of hard issues that WG
> doesn't have time to support. This one takes a few minutes, and the
> workaround while not ideal seems harmless. A simple #ifdef __APPLE__ could
> have even made the workaround only for OSX platforms, leaving Ubuntu
> unaffected.
> Here is the bug/fix: https://code.ros.org/trac/ros/ticket/3626
> It works. Thanks William for the workaround.

I saw that patch, I didn't think that silently disabling logging on OSX was
a good idea.   If you binary search with comments and/or #if 0 blocks, you
can probably figure out what specific lines are confusing the compiler.  I
bet it involves the va_list stuff.   Then we can figure out an actual

Also, the link to the llvm bug in that ticket is broken.  Knowing what the
clang folks have to say would help.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20110831/eccdf7fd/attachment-0002.html>

More information about the ros-users mailing list