[ros-users] Videre STOC Problem

Patrick Goebel patrick at pirobot.org
Sat Feb 12 16:18:42 UTC 2011

I'd like to add another data point to this thread with the new Videre 
STOC camera I recently acquired but I'm having difficulty getting off 
the ground.  The camera works fine under Windows using the SVS software, 
so then I tried it under Ubuntu 10.04 (kernel 2.6.32-25) on the same 
machine (dual boot) and therefore using the same hardware.

Running coriander I get the following error:

"Warning: could not find a Digital Camera on the bus".

So I already suspect something wrong with Firewire under my Ubuntu 
setup.  But I press on anyway.

When first trying to run smallv I got the following error:

"error while loading shared libraries: libraw1394.so.8: cannot open 
shared object file: No such file or directory"

I have set LD_LIBRARY_PATH correctly according to the Videre 
instructions so I did:

sudo ln -s libraw1394.so.11.0.1 libraw1394.so.8

which is the version on my system and now smallv comes up fine. However, 
it does not see the camera on my Firewire port.  In the Debug window I 
see that no IEEE 1394 cards are found:

SVS Debugging Window

Pixel depth: 24
[dSystem] 0 card(s) found, 0 node(s)
[dSystem] No IEEE1394 card found
SVS version 4.4f -- DCS Digital Stereo Interface
MMX presence: 7
0 devices found:

I made sure I am a member of both the disk and video groups and I did a 
chmod 777 on dev/video1394/* so that ls -l dev/video1394/* gives:

crwxrwxrwx+ 1 root video 171, 16 2011-02-12 07:59 0
crwxrwxrwx+ 1 root video 171, 17 2011-02-12 07:59

The output from lsmod includes:

raw1394                22271  0
video1394              13050  0
ohci1394               26950  1 video1394
ieee1394               81181  3 raw1394,video1394,ohci1394

One last thing: I have registration keys for the SVS software, one for 
Windows and one for Linux.  The Windows key was necessary for 
installation but I don't see any reference to how to install the Linux 
key so I don't know if that could be the problem.

No doubt I am missing some key step to setting up Firewire under Ubuntu 
but I am stumped.


On 02/12/2011 12:37 AM, Stefan Kohlbrecher wrote:
> I had similar stuff happen to me with a Philips SPC1300 on our
> humanoid robots. Approx every 500th frame had corruption that looked a
> lot like some parts of the image data array just went missing. IIRC we
> exchanged the USB cable and it worked again. It definitely was a
> hardware issue in our case.
> Sample image:
> http://img96.imageshack.us/img96/2705/cammosaicluise145.png
> 2011/2/12 Antons Rebguns<anton at email.arizona.edu>:x
>> Chris,ch
>>> The problem does not happen in smallv and does not appear to happen in
>>> coriander.  It is present in disparity view when using image_view's
>>> stereo_view node.  videre_stereo_cam's disparity_view displays no disparity
>>> image.
>> I fixed the disparity display, apparently the time stamp on disparity
>> image was missing that is why the synchronizer couldn't get two
>> matching images and did not display anything. I am still not sure what
>> the problem might be. I just plugged in STOC that we have here and it
>> works just fine. The firmware versions are newer though, but I doubt
>> that would cause this problem:
>> Camera Firmware: 07.00
>> Imager Firmware: 0007
>> STOC Version: 04.02
>> I'll keep looking, maybe something jumps at me as I look at the code.
>> Anton
>>> Here's some info about the camera in case it matters:
>>> Camera Firmware: 06.02
>>> Imager Firmware: 0006
>>> STOC Version: 04.02
>>> Thanks,
>>> Chris
>>> On Fri, Feb 11, 2011 at 10:14 AM, Antons Rebguns<anton at email.arizona.edu>
>>> wrote:
>>>> Chris,
>>>> That's a very strange problem you have there. Does the same mangling
>>>> happen in point cloud received from the device? Does it happen in when
>>>> you run the driver in non-STOC mode? Do you see the same problem if
>>>> you run the camera in coriander, for example?
>>>> Thanks,
>>>> Anton
>>>> On Thu, Feb 10, 2011 at 8:48 PM, Christopher Bessent<cmbq76 at mst.edu>
>>>> wrote:
>>>>> Hi all,
>>>>> My group is attempting to use one of Videre's STOC cameras with the
>>>>> videre_stereo_cam node from ua-ros-pkg.  It works fabulously except for
>>>>> the
>>>>> bottom third which appears to repeat the upper right corner of the
>>>>> respective image.  Every once in a while that section will also devolve
>>>>> into
>>>>> complete static.
>>>>> Here's some example images:
>>>>> http://i.imgur.com/g485H.png
>>>>> http://i.imgur.com/J1UO3.jpg
>>>>> The only idea I have left is that we haven't made a
>>>>> calibration/rectification for this camera yet, but I can't imagine that
>>>>> causing this kind of problem.
>>>>> --
>>>>> Chris Bessent
>>>>> _______________________________________________
>>>>> ros-users mailing list
>>>>> ros-users at code.ros.org
>>>>> https://code.ros.org/mailman/listinfo/ros-users
>>> --
>>> Chris Bessent
>>> cmbq76 at mst.edu
>>> Missouri S&T Undergrad Computer Engineering
>>> Eta Kappa Nu - Bridge Correspondent
>>> Robotics Competition Team - Computing Lead
>>> _______________________________________________
>>> ros-users mailing list
>>> ros-users at code.ros.org
>>> https://code.ros.org/mailman/listinfo/ros-users
>> _______________________________________________
>> ros-users mailing list
>> ros-users at code.ros.org
>> https://code.ros.org/mailman/listinfo/ros-users
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users

More information about the ros-users mailing list