[ros-users] Teleoperation with multiple machines

laura galindez laurago894 at gmail.com
Wed Mar 9 02:40:13 UTC 2011

Hello ROS users!

I am trying to teleoperate a pioneer P3AT though a remote computer. I
previously completed this task following the Getting started with P2OS
However I recently reinstalled Ubuntu 10.04 and ROS Cturtle (I had Boxturtle
previously) and things aren't really working this time.

Note. My computer's names are lola for the Dell Studio and XPS por the Dell
XPS. XPS is communicating with the robot and the teleoperation is being
attempted with lola.

1. I first indicated both computer's IP adresses on etc/hosts
2. I then used ping with each other and everything seemed to work just fine.
3. I used netcat on port 3333 communicating from XPS to lola and there was
no problem. However,communication from lola to XPS failed.

I think the problem lays there.

4. Lola is going to be running roscore so I modified its setup.sh and added
the following lines:

export ROS_MASTER_URI=http://lola:11311
export ROS_MASTER_IP=http://lola

5. On XPS' setup.sh I added the following line:

export ROS_MASTER_IP=http://lola

6. I run roscore on lola and RosAria node on XPS and communication with the
robot is established. Rxgrah in both computers shows the /rosout node.

7. When I run the teleoperation node on lola and display rxgraph, RosAria
node is enclosed in two red circles and the following message is displayed:
ERROR: Communication with node[http://XPS:58281/] failed!

8. When I display rxgraph in XPS, however, every node and topic seems to be
connecting just fine.

I was wondering if any of you had any clue of what the problem might be.

Thank you very much for your help.


*Laura Isabel Galíndez Olascoaga
Mechatronics Engineering
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20110308/66f2df20/attachment-0003.html>

More information about the ros-users mailing list