[ros-users] Debian Installation Issues

Willy Lambert lambert.willy at gmail.com
Tue Mar 29 15:52:36 UTC 2011

2011/3/29 Aditi Nagaraj <anagaraj at mit.edu>

> Hey all,
> I followed the Debian installation instructions on the wiki and I'm
> operating on Squeeze and all that. However, I'm encountering an error
> (i think) right after all the files are copied, when dependencies are
> being calculated.
> this is what I see:
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>  libaprutil1-dev : Depends: libpq-dev but it is not going to be installed
> [ rosmake ] rosdep install failed: rosdep script failed with stderr
> {{{
> E: Broken packages
> }}}
> Traceback (most recent call last):
>  File "/usr/local/bin/rosinstall", line 5, in <module>
>    pkg_resources.run_script('rosinstall==0.5.16', 'rosinstall')
>  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 467,
> in run_script
>    self.require(requires)[0].run_script(script_name, ns)
>  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 1200,
> in run_script
>    execfile(script_filename, namespace, namespace)
>  File
> "/usr/local/lib/python2.6/dist-packages/rosinstall-0.5.16-py2.6.egg/EGG-INFO/scripts/rosinstall",
> line 556, in <module>
>    sys.exit(not rosinstall_main(sys.argv))
>  File
> "/usr/local/lib/python2.6/dist-packages/rosinstall-0.5.16-py2.6.egg/EGG-INFO/scripts/rosinstall",
> line 547, in rosinstall_main
>    subprocess.check_call("source %s && rosmake ros%s
> --rosdep-install%s" % (os.path.join(options.path, 'setup.sh'),
> ros_comm_insert, rosdep_yes_insert), shell=True,
> executable='/bin/bash')
>  File "/usr/lib/python2.6/subprocess.py", line 488, in check_call
>    raise CalledProcessError(retcode, cmd)
> subprocess.CalledProcessError: Command 'source
> /home/aditi.nagaraj/ros/setup.sh && rosmake ros ros_comm
> --rosdep-install' returned non-zero exit status 1
> if I try to just continue, I can work through the beginner tutorials
> up till using 'rosdep'
> i also want to work with the stage simulation package, but using
> 'rosmake stage' is returning errors while building the package. roswtf
> returns some stuff about ros master that always fails whenever I try
> to follow it through (sorry, can't replicate the results for some
> reason).
> does anyone have a solution to this? this is the second time I've
> tried installing it, as I had the same error the first time. i chose a
> new directory the second time around, but still does not seem to have
> helped! if I should be doing something more rigorous to uninstall,
> please let me know!
> thanks a bunch,
> Aditi

Hi Aditi,

The place to ask question is now on answers.ros.org, so It is more easaly to
filter and search into database. Please ask a question there,  tag this as
"installation" and "debian" and send me in private the link to your
question, I'll look at it. I have a working Debian installation so you
should end in success.

> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20110329/aeba22e9/attachment-0003.html>

More information about the ros-users mailing list