[ros-users] tf problem in ubuntu natty

Pablo Urcola urcola at unizar.es
Fri May 13 10:40:43 UTC 2011

El 13/05/11 11:00, Pablo Urcola escribió:
> Hi,
> I am having some problems with tf in mynew ubuntu system (11.04).
> When I run two or more nodes publishing transform messages, the tf
> system stops working properly.
> I use a launch file with two static_transform_publisher nodes from tf
> package as follows:
> <launch>
> <node name="localization" pkg="tf" type="static_transform_publisher"
> args="0 0 0 0 0 0 1 map odom 100"/>
> <node name="rxl" pkg="tf" type="static_transform_publisher" args="0.16 0
> 0.4 0 0 0 1 base_link laser_link 100"/>
> </launch>
> As a result, topic tf do not work as expected.  Sometimes it works well
> but, for a while it only publishes one of the transforms or even none of
> them.
> This can be appreciated by echoing the /tf topic or by using view_frames
> node from tf package.
> This configuration works perfectly on a ubuntu maverick installation,
> but we have tried in two different ubuntu natty computers and the
> problem is still there.
> Has anyone noticed this behavior?
> Cheers,
> Pablo
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users
Ok, I think I have found the problem.

There may be some problems between ROS and python 2.7, which is the 
default distribution in ubuntu natty.
I have written a simple "rostopic echo /tf" in c++ and it was working 
fine, receiving all the frames published in th elaunch file as expected.
Even more, i have tested the original launch file using python 2.6 and 
it worked properly.

So i think that the problem is in moving ROS to python 2.7.



More information about the ros-users mailing list