[ros-users] Turtlebot stack on Roomba (need help)

Jan Tuennermann tuennermann at get.uni-paderborn.de
Mon May 16 21:24:12 UTC 2011

Hi Gonçalo,

thanks for the reply.

>Here at the lab we also use Roombas instead of Creates. I have browsed the turtlebot stack but I haven't tried it with the Roombas yet. We also got a couple of Kinects last week but I haven't had the time to go around and plug them to the Roombas.

That's nice, so we can share some knowledge.

> My first shot in the dark would be the fact that some of the stuff in the navigation stack requires a 
> laser scan to work properly, so in order to use the kinect you need to also use a very cool node that 
> comes with the turtlebot stack that grabs de point cloud from the kinect and publishes a laser scan. 
> There are some launch files that show exactly how to do that.

Yes your right, but that part is working perfectly. I can see the
simulated laser scans in rzviz.

> I wrote the roomba_500_series and I used the standard names in ROS, in that regard it should be 
> pretty similar to using the turtlebot create driver.

Thanks a lot for the driver! It's really useful.

> If there are some differences you can always do some remapping on the topics or change some 
> frame_ids. However keep in mind that the turtlebot will fuse data from the encoder odometry with 
> data from a gyro by means of a kalman filter, and I'm guessing you don't have a gyro on your 
> Roomba, so another thing to keep in mind when using the turtlebot launch files.

Hmmm. Maybe that is part of the problem! I did not consider that.

> I will try to run the turtlebot stack on a Roomba with the Kinect tomorrow to see if I can get it to work. 
> In the meanwhile send me the launch files you modified for your setup.

Unfortunately I made some changes in the code (instead of remapping an
setting parameters) and touched several launch files. So I lost track a
bit :-[ .  I will start with a fresh installation tomorrow.
One important change I do remember:
  in kinect_laser.launch you will need to replace the frame-ids'
/kinect_ part with openni  /openni_

I will let you know when I make any progress in getting gmapping running,
but probably you have it runing first :)

thank again,

> Gon?alo Cabrita
> ISR University of Coimbra
> Portugal
>On May 15, 2011, at 4:11 PM, Jan Tuennermann wrote:
>> Hi Everyone,
>> I'm trying to get the Turtlebot stack running on Roomba + Laptop +
>> Kinect. Most of the things work.
>> Unfortunately I cannot get the turtlebot_navigation gmapping_demo
>> running. Move_base keeps complaining " Still waiting on map..." and
>> gmapping spits out " [target=/odom ]: Dropped 100.00% of messages so
>> far. Please turn the [ros.gmapping.message_notifier] rosconsole logger
>> to DEBUG for more information." Every once in a while.
>> I tried different ways to get in touch with the Roomba. The
>> roomba_500_series node is working great for teleoperation and after
>> renaming 'base_link' to 'base_footprint' I think I got the tf's
>> right because rviz can now show the laserscan. (I also needed to change
>> kinect_...   to openni_.. in some places).
>> Still I thought the the problem might be related to the roomba_500_series
>> stuff interfacing differently than the turtlebot_node. So I cloned that
>> node and tried to make it use the Roomba class out of turtlebot_driver
>> instead of TurtleBot. This did not work at all. It complained about not
>> being able toe read on the port, while connecting appears to work. After
>> changing the baudrate it was able to read the desired number of bytes
>> but crashed afterwards. I'm using the roostick for connection, maybe
>> there are more changed needed to make it work? Anyway, I went back to
>> the roomba_500_series node as everything looks fine (except for gmapping
>> not working...).
>> So I'm running out of ideas.  So maybe someone has some ideas...
>> Here a few questions, that might help:
>> - Does anyone have the turtlebot stack running on a similar combination?
>> - How do I enable that loggin mode, that the mentioned error msg requests?
>> - What else does gmapping need that a laserscan to function properly?
>> And here some more info:
>> roswtf says these are unconnected:
>>   * /move_base/local_costmap/obstacles
>>   * /move_base/local_costmap/inflated_obstacles
>>   * /move_base/TrajectoryPlannerROS/global_plan
>>   * /particlecloud
>> and this is a bit strange, because I see the nodes running and proper
>> connections in rviz:
>> ERROR Communication with [/move_base] raised an error: Unable to
>> communicate with master!
>> ERROR Communication with [/kinect_base_link1] raised an error: Unable to
>> communicate with master!
>> ERROR Communication with [/kinect_base_link] raised an error: Unable to
>> communicate with master!
>> ERROR The following nodes should be connected but aren't:
>> * /rviz_1305470350119958706->/move_base (/move_base_simple/goal)
>> * /kinect_base_link1->/rviz_1305470350119958706 (/tf)
>> * /kinect_base_link1->/move_base (/tf)
>> * /kinect_base_link->/move_base (/tf)
>> * /kinect_base_link->/rviz_1305470350119958706 (/tf)
>> thanks a lot in advance
>> jan
>> _______________________________________________
>> ros-users mailing list
>> ros-users at code.ros.org
>> https://code.ros.org/mailman/listinfo/ros-users

More information about the ros-users mailing list