[ros-users] [Discourse.ros.org] [Next Generation ROS/Troubleshooting] Import error No module named 'rclpy._rclpy' cross compiling

Asier ros.discourse at gmail.com
Fri Aug 18 09:47:05 UTC 2017


I am _cross compiling_ ros2 beta2 for a ARM platform. I get the source `. ./setup.sh` done and after I try to launch the python talker but `rclpy._rclpy` cannot be imported. The default Python version is Python 3.5.

The talker written with C++ works perfect.

I also tried to update the `rclpy` repo to the latest version, and I am getting the same error.
root at host:/opt/ros2/# /opt/ros2/lib/demo_nodes_py/talker
Traceback (most recent call last):
  File "/opt/ros2/lib/demo_nodes_py/talker", line 9, in <module>
    load_entry_point('demo-nodes-py==0.0.0', 'console_scripts', 'talker')()
  File "/usr/lib/python3.5/site-packages/setuptools-22.0.5-py3.5.egg/pkg_resources/__init__.py", line 542, in load_entry_point
  File "/usr/lib/python3.5/site-packages/setuptools-22.0.5-py3.5.egg/pkg_resources/__init__.py", line 2569, in load_entry_point
  File "/usr/lib/python3.5/site-packages/setuptools-22.0.5-py3.5.egg/pkg_resources/__init__.py", line 2229, in load
  File "/usr/lib/python3.5/site-packages/setuptools-22.0.5-py3.5.egg/pkg_resources/__init__.py", line 2235, in resolve
  File "/opt/ros2/lib/python3.5/site-packages/topics/talker.py", line 18, in <module>
    import rclpy
  File "/opt/ros2/lib/python3.5/site-packages/rclpy/__init__.py", line 18, in <module>
    from rclpy.impl.implementation_singleton import rclpy_implementation as _rclpy
  File "/opt/ros2/lib/python3.5/site-packages/rclpy/impl/implementation_singleton.py", line 32, in <module>
    rclpy_implementation = importlib.import_module('._rclpy', package='rclpy')
  File "/usr/lib/python3.5/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
ImportError: No module named 'rclpy._rclpy'
I have noticed that are similar errors at Windows platform.

Regards and thanks.

[Visit Topic](https://discourse.ros.org/t/import-error-no-module-named-rclpy--rclpy-cross-compiling/2463/1) or reply to this email to respond.

More information about the ros-users mailing list