[ros-users] [Discourse.ros.org] [Next Generation ROS] Trouble opening package in qtcreator

Firesurfer ros.discourse at gmail.com
Wed Jul 12 12:20:18 UTC 2017

I realized today that I can't open any CMakeLists.txt from any ros2 packages in qtcreator anymore. This worked for me until two weeks ago.

For example if I try opening this package: https://github.com/firesurfer/ros2_simple_logger/
I do the following:

1. Open a shell
2. Source the ros2 workspace
3. Build the workspace the package is in
4. Source this workspace
5. In this terminal I open qtcreator 
6. Then I configure the build folder into a seperate folder (for example qt_build/ros2_simple_logger)
7. I run into this error:

-- Found fastrtps_cmake_module: 0.0.2 (/home/firesurfer/workspace/ros2_ws/install/share/fastrtps_cmake_module/cmake)
CMake Error at /usr/share/cmake-3.7/Modules/FindPackageHandleStandardArgs.cmake:138 (message):
  Could NOT find FastRTPS (missing: FastRTPS_INCLUDE_DIR FastRTPS_LIBRARIES)

Any tipps what I can do in order to resolve this issue?

[Visit Topic](https://discourse.ros.org/t/trouble-opening-package-in-qtcreator/2196/1) or reply to this email to respond.

More information about the ros-users mailing list