[ros-users] [Discourse.ros.org] [Next Generation ROS] ROS2 Beta1 compiled from source - unicode bug

Mikael Arguedas ros.discourse at gmail.com
Fri May 19 08:10:15 UTC 2017

Glad it worked!

[quote="shehz, post:3, topic:1844"]
I thought this step update-locale LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 in the install instructions would have worked inside the container - but it did not.

Thanks for pointing it out, we added the `LANG=en_US.UTF-8` to the install instructions hoping that it would fix this particular issue. Apparently it's not enough. According to [this thread](https://askubuntu.com/questions/581458/how-to-configure-locales-to-unicode-in-a-docker-ubuntu-14-04-container) the entire `update-locale` call has no effect in commandline in docker containers, so it seems that it "has to happen" in the Dockerfile before hitting the entry point.

[Visit Topic](https://discourse.ros.org/t/ros2-beta1-compiled-from-source-unicode-bug/1844/4) or reply to this email to respond.

More information about the ros-users mailing list