[ros-users] [Discourse.ros.org] [TurtleBot] TurtleBot3 - Output from Intel Joule HDMI stopped working

Declan O'Donoghue ros.discourse at gmail.com
Wed Oct 11 15:39:39 UTC 2017

I am working with the TurtleBot 3. The issues I am having are outlined in the following points:
Out of the box, the Intel Joule displayed correctly to a monitor.

I wanted to install Ubuntu Core on the Joule, so a BIOS update was required. To do this, I followed the instructions on https://software.intel.com/en-us/flashing-the-bios-on-joule.

Once the BIOS was flashed into the Joule, the Joule no longer displayed on the monitor (or other monitors I tried). I tried connecting the cable in different orders but it had no effect.

I reflashed the BIOS onto the Joule, with the addition of the -clear option, using the following command: Flash.bat -clear Joule_C0-X64-Release-1J2-Public_DNX.bin (suggested in https://intel-openport-v7.hosted.jivesoftware.com/thread/118328)

The Joule then connected correctly to the monitor and I was able to install Ubuntu correctly. (A second Joule I was working with experienced the same display issue; however, the above solution did not resolve it.)

This worked for a time and I was able to control the TurtleBot3 using the android app, but the Joule returned to the state where it doesn't output from the HDMI.

I have attempted to reflash the BIOS as above, but it had no effect.

The Joule still responds when pinged as it did before the display issue rearose.
How can I resolve this issue to allow the Joule to output correctly to the monitor? Is it possible to restore the Joule to its factory settings?

[Visit Topic](https://discourse.ros.org/t/turtlebot3-output-from-intel-joule-hdmi-stopped-working/2905/1) or reply to this email to respond.

More information about the ros-users mailing list