[Ros-release] roscpp subscriber callback not triggered when sending from Android

Marcus Liebhardt marcus.liebhardt at rnd.yujinrobot.com
Thu Dec 13 09:15:20 UTC 2012

Another problem I ran into today:
When sending messages from an Android app (e.g. Turtlebot teleop sending
geometry_msgs/Twist), the callback of my roscpp subscriber didn't get
I tested this with simple subscriber implementations in roscpp and rospy in
parallel (plus rostopic echo, which is also implemented with rospy AFAIK).
This only happened when sending from Android, so might be a bug there (or
just because we currently can't recompile those apps). When sending from
another 2.Beta Groovy 64Bit Ubuntu machine, callbacks in both
implementations worked fine.

If anybody knows further tests, with which I could narrow down the root
cause, please let me know!


Marcus Liebhardt
Control Engineer
Yujin Robot
주소: 대한민국 서울시 금천구 가산동 345-30 남성프라자 #601, 153-023.
Address: Door #601, Namsung-Plaza, 345-30 Gasan-dong, Guemcheon-gu, Seoul,
153-023, Republic of Korea
Website: http://www.yujinrobot.com
Email: marcus.liebhardt at yujinrobot.com
Phone: +82-70-46577073
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-release/attachments/20121213/6e0aa5fe/attachment-0008.html>

More information about the Ros-release mailing list