[ros-users] ntp and multi-machines

Enea Scioni enea.scioni at student.unife.it
Thu Apr 29 14:44:04 UTC 2010

Hi all!

After trying to use the navigation stack on my platform with success, and
after discovered that unfortunately my embedded board that I use is too less
powerful to run all the navigation stack, I'm trying to run on embedded
board few nodes (driver nodes for my robot) and the "high-level" of
navigation stack on my laptop.

For do this, my laptop (where I run also the master) communicate as well on
wireless with embedded board, and I launch all nodes using a .launch file,
where I set up my driver nodes to run on remote machine.
Nodes, parameters and everything is the same that I used for run everything
on my laptop, and before I tried do control with keyboard, in remote way my
robot, so (I guess) I don't have multi-machine problems.

(But!) When I run the navigation stack, the move_base node can't start
because it's waiting for an odom-map frame transform. Infact I receive the
warning: \map frame doesn't exist. After check that map frame is not
published (amcl should publish it), I checked the amcl node and I received
the warning of 100% dropped on /odom message filter. Usually it means that
there's something wrong in the tf stream, but the nodes and the naming
"stuff" are the same that I used before (And they worked before). So I
thought that probably it could be a time problem and I read that the pr2 has
a similar problem
http://www.ros.org/wiki/pr2_computer_monitor#ntp_monitor.py , or in general,
each robot that runs different nodes in different machines.

So I would like to ask if somebody already had (and resolve) my same
problem, and If the problem could be the different time.
If yes, how can I use the ntp_monitor.py script? I took a look at pr2.launch
file, in pr2_bringup package and I did the same in my launch file, but if I
use rostopic echo diagnostics I receive 2 different messages: one of them,
relative at my laptop ntp adjust, with "level 0", but the other one,
relative at my embedded board, with level 2 (Error running ntpupdate). For
the embedded board, I set up the host to my laptop, where an ntpd run as
well, and If I try to run the command (in a bash shell in embedded board)
"sudo ntpdate laptop", I'm able to upgrade the time, so the ntp server

Thank you!!

Enea Scioni

View this message in context: http://ros-users.122217.n3.nabble.com/ntp-and-multi-machines-tp765453p765453.html
Sent from the ROS-Users mailing list archive at Nabble.com.

ros-users mailing list
ros-users at lists.sourceforge.net

More information about the ros-users mailing list