[ros-users] slam_gmapping messages problem

Enea Scioni enea.scioni at student.unife.it
Fri Apr 23 12:53:11 UTC 2010

Hi all again!
First of all, thanks to brian and erik for replied me!

Now I fixed my problems with tf stream data, and everything seems work fine.
I also tried to use the navigation stack in a "fake enviroment" and It works
fine too.
I wrote "fake enviroment" because I used a fake map: infact I'm not able to
build map using gmapping ros node yet.

If I run my real record data, the gmapping node print on screen just few
information, like:
 -maxUrange 8.09 -maxUrange 8.09 -sigma     0.05 -kernelSize 1 -lstep 0.05
-lobsGain 3 -astep 0.05
 -srr 0.1 -srt 0.2 -str 0.1 -stt 0.2
 -linearUpdate 1 -angularUpdate 0.5 -resampleThreshold 0.5
 -xmin -100 -xmax 100 -ymin -100 -ymax 100 -delta 0.05 -particles 30
[ INFO] 0.000000000: Initialization complete
update frame 0
update ld=0 ad=0
Laser Pose= 0 0 0
m_count 0
Registering First Scan

and that's all. Instead, I expect more information like:
update frame 35                                                                                                      
update ld=1.03982 ad=0.0612444                                                                                       
Laser Pose= -0.116927 -1.9003 -1.90458                                                                               
m_count 3                                                                                                            
Average Scan Matching Score=902.834                                                                                  
neff= 29.6043                                                                                                        
Registering Scans:Done                                                                                               
update frame 39                                                                                                      
update ld=1.03922 ad=0.158316                                                                                        
Laser Pose= -0.359376 -2.91043 -1.74626                                                                              
m_count 4                                                                                                            
Average Scan Matching Score=482.681                                                                                  
neff= 14.5789                                                                                                        
Deleting Nodes: 3 4 6 10 11 12 16 21 22 24 25 26 28 29 Done                                                          
Deleting old particles...Done                                                                                        
Copying Particles and  Registering  scans... Done                                                                    

That usually I gmapping print on screen if I use bagfile by willowgarage or
a bag file created by a simulation (using ros/stage).
I know that these informations are printed from gmapping code/libraries, and
not from the wrapper, but the node appears like in "stand by", like if it's
waiting for something.
If I try to get the map using map_saver, I receive a map with only my last
laser scan.

Anybody knows how I can fix it, or where can I take a look in the code for
understand how fix it?

Thank you again!
Enea Scioni
View this message in context: http://ros-users.122217.n3.nabble.com/slam-gmapping-messages-problem-tp676863p745574.html
Sent from the ROS-Users mailing list archive at Nabble.com.

ros-users mailing list
ros-users at lists.sourceforge.net

More information about the ros-users mailing list