[ros-users] compressed_image_transport not working

Patrick Bouffard bouffard at eecs.berkeley.edu
Sun Jul 25 06:18:39 UTC 2010

I just did an install (from binaries) of cturtle onto a new machine
running Ubuntu 10.04, and things seem to mostly work but I noticed if
I tried to image_view an image topic using compressed transport it did
not work. So I tried:

$ rosrun image_transport list_transports
Declared transports:
compressed (*): Not available. Try 'rosmake compressed_image_transport'.
theora (*): Not available. Try 'rosmake theora_image_transport'.

*** Plugins are not built. ***
 - Provided by package: compressed_image_transport
 - Publisher: This plugin publishes a CompressedImage using either
JPEG or PNG compression.
 - Subscriber: This plugin decompressed a CompressedImage topic.
 - Provided by package: image_transport
 - Publisher: This is the default publisher. It publishes the Image
as-is on the base topic.
 - Subscriber: This is the default pass-through subscriber for topics
of type sensor_msgs/Image.
*** Plugins are not built. ***
 - Provided by package: theora_image_transport
 - Publisher: This plugin publishes a video packet stream encoded using Theora.
 - Subscriber: This plugin decodes a video packet stream encoded using Theora.

.. I'm not sure what to make of this. Why are the compressed and
theora transports 'not built'? If I do a 'rosmake
compressed_image_transport' as suggested, it completes without error
but only because (I think) ROS_NOBUILD is set in that package anyway.
I even tried removing ROS_NOBUILD and running rosmake, which did seem
to complete successfully, yet list_transports still complains.

I don't recall having to do anything special beyond 'apt-get install
ros-cturtle-image-transport-plugins' in the past.


More information about the ros-users mailing list