[ros-users] compressed_image_transport not working

Brian Gerkey gerkey at willowgarage.com
Mon Jul 26 14:42:49 UTC 2010

hi Patrick,

I just tried the latest binaries on a Karmic box, and the transports
are available.  We had some issues last week with our deb-building
system.  Could you try an update and upgrade, to pull the latest
cturtle debs, and see if the problem persists?


On Sat, Jul 24, 2010 at 11:18 PM, Patrick Bouffard
<bouffard at eecs.berkeley.edu> wrote:
> I just did an install (from binaries) of cturtle onto a new machine
> running Ubuntu 10.04, and things seem to mostly work but I noticed if
> I tried to image_view an image topic using compressed transport it did
> not work. So I tried:
> $ rosrun image_transport list_transports
> Declared transports:
> compressed (*): Not available. Try 'rosmake compressed_image_transport'.
> raw
> theora (*): Not available. Try 'rosmake theora_image_transport'.
> Details:
> ----------
> "compressed"
> *** Plugins are not built. ***
>  - Provided by package: compressed_image_transport
>  - Publisher: This plugin publishes a CompressedImage using either
> JPEG or PNG compression.
>  - Subscriber: This plugin decompressed a CompressedImage topic.
> ----------
> "raw"
>  - Provided by package: image_transport
>  - Publisher: This is the default publisher. It publishes the Image
> as-is on the base topic.
>  - Subscriber: This is the default pass-through subscriber for topics
> of type sensor_msgs/Image.
> ----------
> "theora"
> *** Plugins are not built. ***
>  - Provided by package: theora_image_transport
>  - Publisher: This plugin publishes a video packet stream encoded using Theora.
>  - Subscriber: This plugin decodes a video packet stream encoded using Theora.
> .. I'm not sure what to make of this. Why are the compressed and
> theora transports 'not built'? If I do a 'rosmake
> compressed_image_transport' as suggested, it completes without error
> but only because (I think) ROS_NOBUILD is set in that package anyway.
> I even tried removing ROS_NOBUILD and running rosmake, which did seem
> to complete successfully, yet list_transports still complains.
> I don't recall having to do anything special beyond 'apt-get install
> ros-cturtle-image-transport-plugins' in the past.
> Thanks,
> Pat
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users

More information about the ros-users mailing list