[ros-users] Tutorials on simulating PR2 / "high level" tutorials in general

Stefan Kohlbrecher stefan.kohlbrecher at googlemail.com
Wed Mar 17 16:51:17 UTC 2010

Hi Ken,

thanks for the quick fix to the tutorial. I can now execute all launch
commands for the mobile base tutorial without errors. I'm also very
sure that teleoperating the pr2 worked for me at least twice.
Unfortunately, I'm not able to reproduce this right now. Starting
everything up looks good, listening to cmd_vel also prints velocity
commands when using the keyboard node, but the robot refuses to move.
I'm a bit puzzled because it worked before and now it doesn't, without
any obvious change. Any idea about what I'm doing wrong?


2010/3/12 Ken Conley <kwc at willowgarage.com>:
> Hi Stefan,
> Thanks for bringing this up. Our policy is that the tutorials for
> released stacks should all work with Box Turtle, so the pr2_simulator
> tutorials need to be rewritten. I've filed a ticket here for that
> cleanup:
> https://code.ros.org/trac/wg-ros-pkg/ticket/4001
> Sorry for the confusion,
> Ken
> On Fri, Mar 12, 2010 at 8:28 AM, Stefan Kohlbrecher
> <stefan.kohlbrecher at googlemail.com> wrote:
>> Hi,
>> after a quick fix for Box Turtle involving pr2_simulator (thanks Ken),
>> I'm now trying out pr2 + gazebo in simulation. Unfortunately, it seems
>> that the tutorials are severly outdated (or I'm doing something
>> stupid). I did a fresh Box Turtle install. I can successfully do the
>> following:
>> "roslaunch gazebo_worlds empty_world.launch"
>> -Starts gazebo with empty world, as expected
>> "roslaunch pr2_gazebo pr2.launch"
>> -Adds pr2 in Gazebo, as expected. Joints are moving into a default
>> position. rospack complains about missing [wifi_ddwrt] of [webui], but
>> I figure this shouldn't be a problem in simulation.
>> Now, I'd like to do something simple like driving the mobile base
>> around ( e.g. http://www.ros.org/wiki/pr2_simulator/Tutorials/TeleopBaseControllerPR2InSimulation
>> ).
>> Step 3 as described in the tutorial doesn't work, because
>> pr2_default_controllers does not exist. The info output when launching
>> pr2.launch suggests that "base_odometry" and "base_controller" are now
>> loaded by default.
>> Step 4 also does not work, because "teleop_base" does not exist. I
>> searched for "teleop" and found "pr2_teleop" providing
>> "teleop_base_keyboard". Launching this, I can now teleoperate the
>> mobile base (yay!).
>> To make a long story short, I understand that the tutorials can't be
>> kept up to date 'automatically', so wouldn't it make sense to at least
>> systematically note the last ROS version they were tested with? This
>> certainly would help to get an indication how likely one is to succeed
>> in using a given tutorial. I haven't succeeded in applying many of
>> them with Box Turtle, because quite a lot of the stuff described has
>> changed a lot (that, or I'm stupid ;) ).
>> regards,
>> Stefan
>> _______________________________________________
>> ros-users mailing list
>> ros-users at code.ros.org
>> https://code.ros.org/mailman/listinfo/ros-users
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users

More information about the ros-users mailing list