[ros-users] using navigation to move a robot

Tully Foote tfoote at willowgarage.com
Wed Mar 24 21:25:50 UTC 2010

Hi Ben,
Could you please post the configuration files and launch files you are
using.  These will help us diagnose your problem.

The navigation stack is complicated enough that we don't try to run it from
the command line.


On Wed, Mar 24, 2010 at 1:48 PM, Ben Reiter <bkreiter at wustl.edu> wrote:

> Dear Ros-User-Group,
> My name is Ben Reiter, I'm a student a WashU in Saint Louis. I'm trying to
> get our robot to move using the navigation stack, but I'm having some
> issues. I'll try to explain exactly what I'm doing, and what is going wrong.
> At the moment, the robot fails to move at all. In rviz, I can see that the
> transforms all are working, that it can definitely see the laser, and is
> starting to build a map.
> I run:
> Roscore
> Hokuyo_node
> rflex b21 (the interaction with our robot which sets up tf, b21/cmd_vel,
> and a host of other nodes)
> gmapping slam_mapping
> move_base move_base (which starts move_base_node)
> simple_navigation_goals (from this tutorial:
> http://www.ros.org/wiki/navigation/Tutorials/SendingSimpleGoals)
> I'm currently having 2 issues, they might or might not be related.
> First, when I run move_base I try to remap its output 'cmd_vel' to
> 'b21/cmd_vel' by writing "rosrun move_base move_base cmd_vel:=b21/cmd_vel"
> However, this seems to have no effect because move_base still creates a
> cmd_vel topic that doesn't communicate with the b21/cmd_vel.
> Second, and I think more importantly, when I run simple_navigation_goals,
> the output is as follows:
> Waiting for the move_base action server to come up
> Sending goal
> The base failed to move forward 1 meter for some reason
> And then it exits.
> Just after "sending Goal" in simple_navigation_goals, when looking at the
> output of move_base, I get this error:
> [ERROR] 1269463020.665478000: Aborting because a valid plan could not be
> found. Even after executing all recovery behaviors
> I'm not really sure how to fix this, Any help would be appreciated.
> Thanks,
> Ben Reiter
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users

Tully Foote
Systems Engineer
Willow Garage, Inc.
tfoote at willowgarage.com
(650) 475-2827
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20100324/bf37f80a/attachment-0003.html>

More information about the ros-users mailing list