[ros-users] wavefront

Eitan Marder-Eppstein eitan at willowgarage.com
Wed Mar 31 17:24:52 UTC 2010


The Costmap2DROS transform timeouts could be a problem if they don't taper
off after startup. A bunch of warnings right as you start isn't unexpected,
but if they just keep spewing that means there is likely a timing issue. Do
they keep spewing constantly or more or less stop after a few seconds?

After looking at your configuration files, it seems that you're missing a
pretty important line in costmap_common_params.yaml. You define a
"laser_scan_sensor," but you never actually tell the navigation stack to use
it. As such, you'll never see obstacles show up in the costmap. Add the
following line to your costmap_common_params.yaml file:

observation_sources: laser_scan_sensor

This will tell the navigation stack that you'd like to use the
laser_scan_sensor you defined.

Hopefully, adding that line should get obstacles to show up for you.
However, even without that, I would've expected the robot to move when you
set a goal, it would just hit stuff. Are you sure that you were sending a
goal on the correct topic? In rviz, you need to make sure to set the 2D Nav
Goal topic to "move_base_simple/goal." I believe that both rviz and nav_view
by default send to the "goal" topic instead. If you want to use nav_view,
you'll have to remap in your launch file. You can see
move_base_stage/move_base/nav_view.xml for an example of this.

Oh... I think I may know why the robot doesn't move, you've defined your
footprint by only 2 points. The navigation stack supports any convex polygon
for a footprint and, therefore, needs at least three points to run. It also
assumes that the robot is centered at (0, 0). If you want to define a square
robot of the dimensions in your launch file you'll need to use the

footprint: [[-0.2, -0.2], [-0.2, 0.2], [0.2, 0.2], [0.2, -0.2]]

You should have received a warning about this, but I just realized that the
costmap uses ROS_ASSERT where it should be using ROS_FATAL. This means that
all those warnings will be compiled out when run in release mode. I've
ticketed fixing this here: https://code.ros.org/trac/ros-pkg/ticket/3939

Hope this helps and let me know how things go... we'll figure it out yet,


On Wed, Mar 31, 2010 at 8:13 AM, Dan Lazewatsky
<lazewatskyd at cse.wustl.edu>wrote:

> On 3/30/10 7:55 PM, Eitan Marder-Eppstein wrote:
> Hey Dan,
> A few questions for ya to help figure out what's going on:
> 1) Have you tried using the rxconsole tool to see if any useful information
> is being output from the system? If so, did you see anything that seemed to
> be complaining or giving warnings?
> rxconsole doesn't show anything that seems too concerning. The worst is a
> bunch of
> Costmap2DROS transform timeout. Current time: ...
> 2) What launch files are you running on the erratic? Are they the ones in
> the 2dnav_erratic package? Or different ones that you created? We used to
> have an erratic in-house, but we don't anymore and its been awhile since the
> 2dnav_erratic package has been tested. If you're running with your own
> configuration, could you post the files so I can take a look at them?
> I've attached the launch file and config files I'm using. The config files
> were all setup according to this:
> http://www.ros.org/wiki/navigation/Tutorials/RobotSetup
> 3) Do you see any obstacles in nav_view? On second thought, rviz is a more
> powerful debugging tool for this kind of stuff. Have you tried using rviz to
> get useful debugging information (whether obstacles show up, a plan is
> created, etc)? You can find a tutorial on using rviz with the navigation
> stack here:
> http://www.ros.org/wiki/navigation/Tutorials/Using%20rviz%20with%20the%20Navigation%20Stack
> nav_view and rviz don't show any obstacles, plan, or really anything but
> the map. If I'm really lucky, rviz will show the amcl particle cloud.
> Ok... take a shot at answering these and we'll see if that gives a bit more
> insight into what's going on.
> Hope all is well,
> Eitan
> On Tue, Mar 30, 2010 at 3:57 PM, Dan Lazewatsky <lazewatskyd at cse.wustl.edu
> > wrote:
>>  Thanks for the response Eitan -
>> I've created a map, and am trying to get an erratic to navigate in said
>> map using nav_view. I set up the robot according the the nav robot setup
>> tutorial, and when I run nav view I can see the map and set the robot's
>> initial pose, but trying to set the goal doesn't seem to do anything. I get
>> a printout from nav view saying "setting goal: Position(...)" but that's
>> all.
>> -Dan
>> On 3/30/10 4:31 PM, Eitan Marder-Eppstein wrote:
>> Dan,
>> The wavefront package has fallen into a bit of disrepair as we favor our
>> move_base package for autonomous navigation. If you're looking to run some
>> autonomous navigation demos, check out the move_base_stage package instead
>> of the 2dnav_stage package. The 2dnav_stage package will probably be removed
>> in the near future to save people the confusion.
>> Hope this helps,
>> Eitan
>> On Tue, Mar 30, 2010 at 12:07 PM, Dan Lazewatsky <
>> lazewatskyd at cse.wustl.edu> wrote:
>>> Hi all - I'm having some trouble using wavefront. When I try to start it
>>> I get this:
>>> robotics at tears$ rosrun wavefront wavefront
>>> terminate called after throwing an instance of 'ros::InvalidNameException'
>>>   what():  Using ~ names with NodeHandle methods is not allowed.  If you want to use private names with the NodeHandle interface, construct a NodeHandle using a private name as its namespace.  e.g. ros::NodeHandle nh("~");  nh.getParam("my_private_name"); (name = [~dist_eps])
>>> /home/robotics/ros/ros/bin/rosrun: line 35: 15562 Aborted                 $exepath "$@"
>>> Granted, I don't know what the right way to use wavefront since the
>>> documentation is a bit spotty.
>>> Any ideas would be appreciated.
>>> Thanks,
>>> -Dan
>>> _______________________________________________
>>> ros-users mailing list
>>> ros-users at code.ros.org
>>> https://code.ros.org/mailman/listinfo/ros-users
>> _______________________________________________
>> ros-users mailing listros-users at code.ros.orghttps://code.ros.org/mailman/listinfo/ros-users
>> _______________________________________________
>> ros-users mailing list
>> ros-users at code.ros.org
>> https://code.ros.org/mailman/listinfo/ros-users
> _______________________________________________
> ros-users mailing listros-users at code.ros.orghttps://code.ros.org/mailman/listinfo/ros-users
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20100331/70cc9564/attachment-0003.html>

More information about the ros-users mailing list