[ros-users] Creating new world file

pratyush jalan pratyush.jalan at gmail.com
Wed May 5 02:04:02 UTC 2010

Hi Everyone,

1) I am trying to create my own world file for Gazebo but when I launch my
world it gives an error that the "Image is not grayscale". I created a
simple image in paint with a white background and a path with black color. I
tried using different colors as well but I get the same error each time. Can
you suggest what might be the problem ?

2) I am trying to run my controller code on the simplecar.model but the
problem is the car does not move. My code works for the pr2 robot
(pr2_simulator). I am able to spawn the object in the Gazebo simulator. I
get the following message when I spawn the object -:
core service [/rosout] found
process[spawn_simplecar-1]: started with pid [3814]
[ INFO] 37.267000000: waiting for gazebo factory, usually launched by
'roslaunch `rospack find gazebo`/launch/empty_world.launch'
[spawn_simplecar-1] process has finished cleanly.
log file:
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
Is this an error code ? I wasn't sure because the object is still getting
spawned in the simulator.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20100504/62ce9cdd/attachment-0002.html>

More information about the ros-users mailing list