[ros-users] Creating new world file

John Hsu johnhsu at willowgarage.com
Wed May 5 02:23:26 UTC 2010

Hi Pratyush,

On Tue, May 4, 2010 at 7:04 PM, pratyush jalan <pratyush.jalan at gmail.com>wrote:

> Hi Everyone,
> 1) I am trying to create my own world file for Gazebo but when I launch my
> world it gives an error that the "Image is not grayscale". I created a
> simple image in paint with a white background and a path with black color. I
> tried using different colors as well but I get the same error each time. Can
> you suggest what might be the problem ?

Please clarify the context... are you trying to use a heightmap?  If so, the
image needs to be saved as a grayscale image (single channel).  Note that
this is not the same as using a color image (multiple channels) with black
and white colors.

> 2) I am trying to run my controller code on the simplecar.model but the
> problem is the car does not move.

are you using the pr2 mechanism controller stack?  If possible, please post
relevant world/model/launch files, to help with the debugging process.

> My code works for the pr2 robot (pr2_simulator). I am able to spawn the
> object in the Gazebo simulator. I get the following message when I spawn the
> object -:
> core service [/rosout] found
> process[spawn_simplecar-1]: started with pid [3814]
> [ INFO] 37.267000000: waiting for gazebo factory, usually launched by
> 'roslaunch `rospack find gazebo`/launch/empty_world.launch'
> [spawn_simplecar-1] process has finished cleanly.
log file:
> /home/stk/.ros/log/8f48d09e-57c6-11df-91b7-0024e82035d7/spawn_simplecar-1*.log

looks fine so far...  Did you hit ctrl-c here?


> all processes on machine have died, roslaunch will exit
> shutting down processing monitor...
> ... shutting down processing monitor complete
> Is this an error code ? I wasn't sure because the object is still getting
> spawned in the simulator.
> Thanks.
> Pratyush
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20100504/f2e2df7b/attachment-0003.html>

More information about the ros-users mailing list