[ros-users] Problem of running rviz on a virtual machine

ros_user at yahoo.co.jp ros_user at yahoo.co.jp
Tue May 25 10:59:22 UTC 2010

Hello, all

I am new in ROS system.
I started to subscribe this mailing list this month,
so my problem might be solved already.
The problem is quite common, and I think it's better ask it to professionals.

The problem I have is already mentioned in "No OpenGL Support" in following URL.


I installed ROS system on a Vmware virtual machine with Ubuntu 9.04 distribution.
The virtual machine is on Windows XP Professional SP3.
My laptop is lenovo X61, which has Mobile Intel(R) 965 Express Chipset Family as a video card.

The version of the virtual machine is...

# uname -a
Linux ubuntu 2.6.28-18-generic #60-Ubuntu SMP Fri Mar 12 04:40:52 UTC 2010 i686 GNU/Linux

And when I execute "rviz", I got an error.

# roscore
# rosrun rviz rviz
rviz: OgreGLSupport.cpp:57: virtual void Ogre::GLSupport::initialiseExtensions(): Assertion `pcVer && "Problems getting GL version string using glGetString"' failed.
/opt/ros/boxturtle/ros/bin/rosrun: line 35:  7245 Aborted                 $exepath "$@"

As the web page suggests, I turned on "3D graphics acceleration" in the virtual machine setting,
(there is a setting for the acceleration in VMware workstation)
and I checked whether 3D acceleration is working.
and I got

# glxinfo | grep render
direct rendering: Yes

in the virtual machine. It seems to be OK, but the rviz still give the same error.
I tried to fing a driver of the video card. (Mobile Intel(R) 965)
However, I couldn't find it for Ubuntu.
Do you know any suggestions? or is there actually a driver for that?

In the virtual machine, the video card is still recognized as following.

# lspci | grep VGA
00:0f.0 VGA compatible controller: VMware Inc Abstract SVGA II Adapter

Is this a problem?
I am also quite wondering if my xorg.conf is OK.

# less /etc/X11/xorg.conf

...(some comments)...

Section "Device"
    Identifier    "Configured Video Device"

Section "Monitor"
    Identifier    "Configured Monitor"

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"


I don't know if this is enough information to solve this problem.
Any advices are welcome, solution for any other video cards is also welcome.

Thanks in advance.


2010 FIFA World Cup News [Yahoo!Sports/sportsnavi]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osuosl.org/pipermail/ros-users/attachments/20100525/0cf18c03/attachment-0002.html>

More information about the ros-users mailing list