[ros-users] logitech_pantilt

Dan Lazewatsky lazewatskyd at cse.wustl.edu
Thu May 6 22:42:14 UTC 2010

Rob: I grabbed mjpg_streamer from sourceforge and ran your script,  
which seemed to have no effect. Do you just run it and then fire up  
the logitech_pantilt node afterwards?

Blaise: I tried a bunch of different values up to 1e6, none of which  
caused any visible movement.

I fired up the camera in Windows using logitech's software to confirm  
that the pan and tilt do indeed work, which they do.

On May 6, 2010, at 1:20 PM, Rob Wheeler wrote:

> On one system we use, the camera needs to be initialized correctly.
> The mjpg_streamer program  performs the correct initialization.  We
> just run that program and then kill it shortly thereafter:
> export MJPG_ROOT=/usr/local
> $MJPG_ROOT/bin/mjpg_streamer -i "input_control.so -d /dev/video0"  -o
> "output_http.so -w /usr/local/www -p 8081"&
> sleep 2
> killall mjpg_streamer
> On Thu, May 6, 2010 at 8:26 AM, Blaise Gassend <blaise at willowgarage.com 
> > wrote:
>>> Thanks, I don't know how I missed that.
>> It probably isn't in the default installs.
>>> I got the node running with a joystick, and I can see it printing  
>>> out
>>> stuff like
>>> [ INFO] 1273095684.837439000: PanTilt moving pan=0, tilt=5
>>> but I can't get the camera to actually move. Is there some magic I'm
>>> missing?
>> I know that the node works because we use it, but I haven't actually
>> interfaced with it directly. Have you tried moving by larger amounts?
>> Perhaps you need tilt to be 1000 or 1e6 before you start getting  
>> visible
>> motion.
>> Blaise
>> _______________________________________________
>> ros-users mailing list
>> ros-users at code.ros.org
>> https://code.ros.org/mailman/listinfo/ros-users
> _______________________________________________
> ros-users mailing list
> ros-users at code.ros.org
> https://code.ros.org/mailman/listinfo/ros-users

More information about the ros-users mailing list