[ros-users] rosmake error

Michael Wrock mike.wrock at gmail.com
Tue Oct 19 15:58:09 UTC 2010


I'm fairly new to ros, but I haven't seen any documentation on this issue.

I'm using an existing package that I know already works. It's called
omnibot, so I used rosmake omnibot and everything compiled fine. I
started writing a new .cpp file and added it to the package and
compiled it fine. Since there are 15 files that need to compile, I
tried to guess how to compile just the new .cpp I made, called
PowerCube. I ran the command rosmake omnibot PowerCube, I'm not sure
what happened there, but now I cant run rosmake omnibot! When I try, I
get the following response:

working on omnibot
Unable to create temporary cache file:
[rospack] failed to create tmp cache file
[rosmake] Couldn't determine dependencies for package omnibot. Maybe
it was a stack?
omnibot was neither a stack or a package.

Any idea what changed when I ran rosmake omnibot PowerCube? How can I
reverse it?


More information about the ros-users mailing list