[ros-users] RViz crashing when viewing an model

Hörður Jóhannsson hordurj at gmail.com
Wed Oct 27 20:59:45 UTC 2010

This happens each time I try adding the Robot Model display. I tried
commenting out the textures in the materials.urdf.xacro in the
pr2_description package. But it crashes with the same error. Running
pr2_gazebo pr2_empty_world.launch results in a similar crash.

[25998.921563] gazebo[19826]: segfault at 0 ip 015183e1 sp bfcca030 error 6
in libfreeimage-3.14.1.so[13b8000+30e000]

I'm not sure what files it is trying to load. I can try to find out. Could
there be some library versioning issues?


On Wed, Oct 27, 2010 at 4:16 PM, Josh Faust <jfaust at willowgarage.com> wrote:

> Was this a one-time thing, or is it reproducible?  Any chance you can
> figure out which image it's trying to load, and whether or not it's a valid
> image?
> Josh
> 2010/10/27 Hörður Jóhannsson <hordurj at gmail.com>
>> Hi
>> I'm having a problem displaying the PR2 model in RViz. I was trying out
>> the pr2_build_map_gazebo_demo. When I add a Robot Model in rviz it crashses
>> with the following message
>> [ WARN] [1288200457.838841961]: wxWidgets Warning [tiff module:
>> TIFFReadDirectory]
>> [ WARN] [1288200457.839688381]: wxWidgets Warning [TIFF library warning.]
>> /opt/ros/cturtle/ros/bin/rosrun: line 35: 28068 Segmentation fault
>> (core dumped) $exepath "$@"
>> Running dmesg I get
>> [13705.992256] rviz[28068]: segfault at 0 ip 0575c3e1 sp bf922890 error 6
>> in libfreeimage-3.14.1.so[55fc000+30e000]
>> I'm running on Ubuntu 10.04 and using the binary version of cturtle. Has
>> anyone had similar problem?
>> Thanks,
>> Hordur
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ros.org/pipermail/ros-users/attachments/20101027/dcfb67a8/attachment-0003.html>

More information about the ros-users mailing list